Drobo FS suddenly stopped working, no fan or lights.

I have a Drobo FS. It suddenly stopped working yesterday. I thought it might be the power supply since it’s completely dead, there is no fan or lights or anything. The power supply brick does have a green light on, so I’m guessing it’s not a power supply issue.

Everything was working fine up until then.

I recently updated the firmware a few days ago.

Any suggestions, or am I SOL?
(Have to buy a new 5N and hope the drives come back with the data in tact?)


hi derek, can i check if the drobo worked fine since after those updates a few days ago, and that it just suddenly stopped yesterday?
if so, it may just be something had a fault in the main unit. (when my Drobo-S gen2 unit failed, i was able to follow the migration process to essentially move my drives into replacement model of same type, and the process worked smoothly)

could you check again, just to be sure that the power light didnt come on red on the main unit itself with nothing else lit? (that could be an overheating issue)

if the psu is ok, and if no other lights came on, then one thing you could try is to test the main unit such as with the following:

  • to power all down
  • to unplug the power and connection cables from drobo
  • to remove all drives (remembering the order)
  • to power up the empty drobo on its own
    (does it happen to get any further here?)

if it still does not powerup, then aside from buying another psu (just in case), then it is probably the unit rather than the disk pack drives, in which case a migration will hopefully work fine for you too

the migration page has some useful info about your migration options, and there are a couple of different ways to go from a drobo-fs to a drobo-5n, and can be found here:

(banzaiiiii) :smiley:

Thanks for the tips. I did test as you suggested, but no luck, still completely dead.

However, I did take your suggestion to try another psu and voila - it worked!!!

The green light is on the power brick, and the cable is not crimped in any way, nor is the connection loose or frayed. What ever, it’s a much cheaper fix than buying a new unit.


thanks for the update derek am glad that fixed it and you are back in business :slight_smile:

(usually the psu is the first thing to be hit by a power surge or power spike, so its possible something like that happened over there for you… i have my drobos behind surge protectors, as well as the device it connects to, and maybe a surge protector could help for the future in your case too - i think some decent ones are only about £10-£15 over here)