Drobo

Drobo FS - rsync not working

Can anyone help me?

I want to use our Drobo FS as an off-site backup for our Synology NAS. In theory, it is possible with rsync, but getting it to work is a challenge. Can anyone explain it in terms I can follow?

So far I have:

  • Enabled DroboApps.
  • Installed rsync.
  • Edited the rsyncd.conf file:

[Shares]
path = /mnt/DroboFS/Shares/Drobo
comment = DroboFS Share
read only = false

  • Installed Open SSH.
  • Allowed rsync, SSH & Hyper Backup ports through firewalls at both locations.
  • Given the Drobo FS a static IP address.

Now I am trying to setup a backup with Hyper Backup (on Synology):

  • Add new backup task -> rsync
  • Choose rysnc-compatible server
  • Input Drobo FS static IP address
  • Transfer encryption (tried both on and off)
  • Add Admin username and password
  • Backup module *
  • Directory - I have put “Drobo FS” but I’m not sure what I’m meant to put here - I can’t put a path

*This is where it gets interesting.
Having transfer encryption off, using port 873 doesn’t work:
Annotation 2020-09-03 111935
Having transfer encryption on, using port 22 or port 873 gets the same error. I did also get a different error on Tuesday with on, port 22, which said: “No response from the destination server. Please check your network status and try again later.” (Network status was fine and my Drobo was showing in Drobo Dashboard.) I cannot replicate the error now.

I’ve looked at other topics but I am so lost. I don’t know how to login to SSH and no one explains how to actually do it (I have looked!). I cannot install DroboAdmin because I cannot find a download file anywhere. I am only assuming:

[Shares]
path = /mnt/DroboFS/Shares/Drobo
comment = DroboFS Share
read only = false

is correct for my setup. My Drobo is called “Drobo”, but the share I actually want to install the backup to is called “Synology”, where do I add that in the above?