Drobo

Drobo FS on Fedora tar backups fail w Input/output error, Child returned status 1

We’re been running tar/gzip backups for a while on Fedora 25 Linux servers and we’d like to make sure aquota.user files get backed up. From the comments in the drobo-backup.conf file here’s what we have:

[code]# Because aquota.user cannot have its atime reset, tar will give

an error status=2 if --atime-preserve is used when backing it up.

We don’t want to lose the backup of this file but we also don’t

want to routinely ignore tar status=2. Solution is to make

–atime-preserve a per-backup argument and omit it when backing

up aquota.user separately.[/code]

However when running via cron the email notification comes back with:

[code]/bin/tar: home/users/aquota.user: Cannot utime: Operation not permitted
/bin/tar: Exiting with failure status due to previous errors

Backup of /home/users FAILED

Failed to rename /home-users-new.tgz to
/home-users-FAILED.tgz: File exists
Backed up /home/users/aquota.user to
/home-users-aquota.user.tgz

gzip: stdout: Input/output error
/bin/tar: Child returned status 1
/bin/tar: Error is not recoverable: exiting now

Backup of /home FAILED[/code]

Here are the options in the config file:

tarargs= --one-file-system --warning=no-file-ignored --warning=no-file-changed --warning=no-file-removed
backup = /home/users --atime-preserve --exclude=aquota.user --exclude=.gvfs --exclude=--exclude-ignore-recursive=S.gpg-agent --exclude=.adobe --exclude=.config/libvirt/qemu/lib/capabilities.monitor.sock --exclude=.dropbox --exclude=home/users/*/.cache --exclude=.fontconfig --exclude=csga/*/S.gpg-agent --exclude-caches-all
backup = /home/users/aquota.user
backup = /home --atime-preserve --exclude=.gvfs --exclude=.gnupg
backup = /etc --atime-preserve
backup = /root --atime-preserve --exclude=.cache --exclude=.cache/keyring-* --exclude-caches-all
backup = /usr/local --atime-preserve
backup	= /var/lib --atime-preserve --exclude=var/lib/rpm --exclude=var/lib/yum --exclude=mysql/mysql.sock --exclude=gssproxy/default.sock --exclude=samba/private/msg.sock
backup	= /var/backup --atime-preserve
backup	= /var/log --atime-preserve
backup	= /var/spool --atime-preserve
backup	= /var/www --atime-preserve

Is there a better way?

I received a reply from one of the GNU tar maintainers:

So in our [font=Courier]/etc/drobo-backup.conf[/font] file, we can’t have any exclude options in the backup directive like we had:

backup = /home/users --atime-preserve --exclude=aquota.user  --exclude=.gvfs --exclude=--exclude-ignore-recursive=S.gpg-agent

Once we changed it to simply:

backup = /home/users

And placed them in this directive:

tarargs= --one-file-system --warning=no-file-ignored --warning=no-file-changed --warning=no-file-removed --use-compress-program=pigz  --atime-preserve --exclude=.gvfs

No more errors. So I simply created a separate cron backup to backup just the [font=Courier]aquota.user[/font] file.