Drobo

Drobo FS no longer spins down after installing HDDs in remaining bays

I originally outfitted my Drobo FS with 3 HDDs when I bought it. I had it set to spin down after 15 minutes, and it worked perfectly.

Installed 2 more HDDs in the remaining bays last week, and now Drobo will not spin down anymore, no matter the setting. I can hear the fan at full speed, and when I access my shares, it’s always on/instant (doesn’t take the couple seconds to wake up anymore).

Using latest firmware & dashboard.

Any ideas? TIA!

Do you have a lot of data stored on your FS? It might still be redistributing the data in the background.

2.80 TB

That’s a good point; wasn’t sure how long that process would take. It’s been 8 days so far.

You have roughly half the amount of data I have on my 4x2TB Drobo. It should NOT be taking thing long. I replaced a drive in my Drobo and it took fewer than 4 days to finish relayout.

The FS has a faster CPU, so the only possibility I can think of aside from some Drobo FS “confusion” is that some client is accessing data.

I would try disconnecting the network connection on the FS and see if it finishes over the weekend.

I think it has to do with Windows 7…

I had three clients: 2x Vista and 1x XP…everything worked perfectly. Upgraded one of the Vista clients to W7 at about the same time I added the 2 additional HDDs to Drobo…drives stopped spinning down. Uninstalled Drobo Dashboard from all clients and removed Drobo from the network (unplugged ethernet)…drives spun down. Plugged Drobo back into the network and installed Drobo Dashboard only on the W7 client…drives don’t spin down anymore.

Will try a few more different combinations, but this is highly disappointing…

Check if Win7 is indexing the Drobo contents.

I unplugged the Drobo FS (firmware 1.1.1) from my network for a week. Drives spun down. Uninstalled Drobo Dashboard from all of my clients. Plugged Drobo back into the network. Installed Drobo Dashboard (1.7.3) only on my Win7 machine. Made sure under Win7 “Indexing Options” that there were no files/folders from Drobo being indexed (I didn’t see where I could select any Drobo folders, even if I wanted to). Drives aren’t spinning down anymore (all other settings work as normal - dim lights, Drobo Copy, etc.).

I just don’t know if I’m missing something. This is very frustrating.

hi do you have any scheduled tasks?
eg backups, virus scans, etc?

also, what happens if you shut down windows completely… does the FD eventually go into its shutdown mode?
(have to admit im only familiar with drobo v1 and v2 but assuming fs goes to standby mode if nothings plugged into it from a computer cable point of view?)[hr]
actually, one nifty trick is to run sysinternals “process explorer” or something similar which can let you search dlls/handles

then search for your drive letter(s) your FS is using…

eg a few times, my b: volume was being locked by some game install demo i ran and i was able to force close the game file handle and it unlocked my letter. (and at least this way you could report back on what, if anything, is using it)

Hi, Paul!

I ran Process Explorer, searched for my Drobo drive letter, and found svchost.exe running a process on my Drobo drive. I went ahead and got rid of it; I’ll let you know how it goes. Thanks for the suggestion!

I think that really is a great workaround…

Forgive me, as I really don’t know exactly what I’m talking about, but removing the svchost.exe handle that is linked to the Drobo network mapped drive via “Process Explorer” seemed to do the trick. Everything still works, the only difference being the mapped drive has the little red “x” on it, and all of the root folders appear as “Read-only” when viewing their Properties; however, I can still move/copy files to any of the Drobo folders, as normal. DroboApps still works (I can still connect to DroboApps Admin via browser, etc.), DroboCopy, everything. …oh, and Drobo correctly spins down once again!!

I’ll let y’all know how it goes in the long run, but Paul’s suggestion seemed to be the fix I was looking for. Thanks again!

I definitely spoke too soon…drives are not spinning down…

Back to square one.

ouch, am glad the post had a bit of hope :slight_smile:

(i wasnt actually expecting you to start zapping processes thoughl… just to report back first :slight_smile: but glad that nothing bad happened.)

i’ll ahve to scratch my head some more, while others chip in :)[hr]
btw it might be worth raising a support ticket with DRI, and maybe they can look at your logs/diagnostig logs just in case it contains info on something that might be happening/or maybe a drive in correction mode etc?

Do Drobos have some type of log file that tracks processes to narrow down which one is actively seeking the drives?

You could try IOtop.

Uninstall Dashboard 1.7.3 with the uninstall utility, reboot and after that install Dashboard 1.6.8.

I tried 1.7.3 and 1.8.3., I didn’t bother with 1.8.2 - all i got was Drobo problems. I went back to 1.6.8. and Drobo is working like it used to.

I’m on OS X but it might help you on Win 7 as well.

m.

Please forgive my ignorance, but wouldn’t a more relevant suggestion be to simply not use the Dashboard at all? I keep it installed (latest version), but never use it unless I actually want to change some configuration on the FS

I run the Dashboard maybe once every month, just to have a look. I have configured the FS to send me an email in case of trouble, in any case.

I always mount my shares using the normal means, since I never trusted the Dashboard to do a proper job of it (constantly hanging while mounting/unmounting, sometimes not seeing that the Drobo is right there, etc…).

So, in all honesty, besides for the basic configuration during the first 30 minutes or so with the FS, what do you need the Dashboard for?

That’s the only thing he changed and is very easy thing to do. He can still upgrade to 1.7.3 or 1.8.3 or what ever the latest version is at the moment.

m.