Drobo

Drobo FS Linux share keeps going off line

We have a Drobo FS firmware 1.2.7 with Dashboard 2.6.4 and its mounts keep going off line every few days. Reboot fixes it. There is a red light indicating low disk space, still ~ 160 GB.

The error we see is:
ls: cannot access '/mnt2': Host is down

The errors I see from the DDDiags_ file are:
Error - DroboDevice::SendCommand() - Failed to send the command with error 6

From TMDiags_

TM: 00003574 03\26 09:36:24 Error - DroboFSAdapter::InsertConfig - session is NULL
TM: 00003574 03\26 09:36:24 Error - DroboFSAdapter::GetConfig - Network - Failed to get and insert the config info
TM: 00003574 03\26 09:36:24 Error - ESANASDevice::GetIPAddresses - Error getting the IP address(s). Error = 7
TM: 00003574 03\26 09:36:24 Error - PNPManager::GetDeviceWithIP() - Failed to get the IP address for device 0dd120170341
TM: 00003418 03\26 09:36:26 Error - DroboFSAdapter::GetDimming() - Session is NULL
TM: 00003418 03\26 09:36:26 Error - ESANASSession::sendCommand() - Not connected
TM: 00003418 03\26 09:36:26 Error - DNASShareManager::ManageNASDevice - DNASConfiguration is not OK. Not adding share info for 170341
TM: 00000128 03\26 09:36:26 Information - ServiceCmdRouter::RouteCommand - DeviceID = 0dd120170341.  CmdID = eCmdGetFirmwareInf
TM: 0000031c 03\26 09:36:31 Information - ESAAlertHistory::Update - ESA status change for ID 0dd120170062 - 0x4 to 0x6
TM: 00003418 03\26 09:36:44 Error - DNASESAUpdateHelper::getDiskPackID - Failed to get diskpack ID from ESA Update
TM: 00003418 03\26 09:36:44 Error - DNASShareManager::ManageNASDevice - DiskPackID is 0 or null.  Using serial number.

I tried that old Ruby decryptor on the DroboDiag encrypted log file but it just appears to create a binary file. Is there a special Ruby viewer for that?

Check all your network infrastructure, cabling etc.
You might try reinstalling the Drobo firmware, just be aware if communication fails during the process there’s a chance of bricking it.

If that doesn’t help by eliminating the highly unlikely case that it’s corrupt firmware, then it’s probably hardware which given the end of sale date is a minimum of 10 years old, & given the security implications of using an FS & SMBv1 it might simply be time to update to something newer & more modern that’s still supported.

I’d also try a dedicated power supply if you’re currently going through a power strip/surge protector of some kind. Good luck

Thanks for the response. I take it Drobo is no longer offering the $99 support? I opened a case earlier no acknowledgement yet and their 866 phone number is disconnected. Is there a way to decrypt the log file? I found the Ruby script but all it does is output a binary file. I don’t want to risk reinstalling the firmware. I’m running a rsync now to get what’s on there. Hoping it can stay connected long enough.

I know I had some staff running Jupyter notebook scripts and perhaps a lot of I/O intensive tasks. I’m wondering if that is what could be causing this?

Thanks these are connected to a huge UPS that is a part of the server rack, not many other options there. I was hoping to get a way to decrypt the logs or the logs I did provide have some clues.

I have no idea what Drobo’s position is for support on an FS if you buy the one off option, all I can say for sure is they stopped selling DroboCare for those in 2011, which means they fell out of that support level a year later.

I’ve encountered a situation before where a network adapter/driver would crash if the traffic was sufficiently heavy, I suppose that’s a possibility. The processor on Gen 2 devices like the FS is also pretty anaemic, so heavy I/O combined with scripts running may also be related.

Afraid I don’t know how you’d decrypt the log, have you actually looked at the binary file you got from the script you tried using a hex editor or similar?

If it’s being fed through a UPS, then the power quality should be pretty good, the power bricks themselves have been known to become weak with age though (capacitors deteriorating etc.).

Yes tried all the options suggested here:

Here is the original script:

#!/usr/bin/env ruby
ARGV.each do |filename|
File.open(filename,'rb') do |infile|
File.open("#{filename}.text",'wb+') do |outfile|
infile.each_byte { |x| outfile.write format("%c", x ^ 0xc3) }
end
end
end

Edit, I also tried, whiteout success:

<?php
$fp=fopen("$argv[1]", 'r');
while(!feof($fp)) {
$char=fgetc($fp);
echo chr(ord($char)^0xc3);
}
?>