Drobo fs hanging whlie data-loss-protection process

Hi to all drobo lovers.

I do love my drobo fs but at the moment I quiet go crazy with it.

I already wrote a post but in the false category. See here. http://www.drobospace.com/forums/showthread.php?tid=146870

How ever. After realizing the drobo fs can’t handle with a 6TB disk I bought a 3TB disk. But unfortunately it ended up in the same result.

What do I have:
Drobo FS with 5 x 2TB = 10TB and single protection. So I got around 7.5 TB space for data and at the moment I used around 5.5 TB which mean I do have more than 1.5 TB free space.

What I did:
Going Back to the initial failure of that case. Shut down everything and put in the old failure 2 TB disk. The drobo fs stared up. The drobo dashboard showed up the drobo the 3rd bay (the failure disk) has a solid red light. Also the same in drobo dashboard. It told me to replace that 3rd disk with a new one.
I removed the old (red light) disk an replaced with my new 3TB disk. That new disk was recognized by drobo fs and also in drobo dashboard. After a little while I all the drobo fs disk lights were flashing green-yellow an drobo dashboard that the data loss prevention process has started. Duration 19 hours. At the next day I was checking all the light at the drobo. Solid yellow shining. Then checked drobo dashboard. Drobo dashboard showed me green yellow flashing und duration of the process still 12 hours. I did not touch anything and did not used any ressources of the drobo fs.
After another half day the light an drobo still yellow solid but the drobo dashboard could not find any connected drobo. On Mac finder, drobo fs is shown as a network resource but not able to connect to it.

May someone of you does have a solution or some ideas for me.

Thanks daniel

thanks for the clarification in your 1st, linked post daniel,

it seems that the drive you replaced, had not actually failed, but that it was a drive that drobo / dashboard had indicated as a drive to be upgraded, indicating that it would like some more space. (this doesnt necessarily change the fact of the issue but just to mention, as i believe it would have been flashing red if it had truly failed).

if all drives were the same size, then it is possible that the drobo preferred the other 2TB drives in some way, and that could be why it showed you a particular drive with solid red (rather then usually just showing the 1st smallest drive in the pack)

with your current situation, i am not sure why the main drobo unit would be different to the dashboard, but since it is possible for dashboard and computer to lose access to the drobo during a rebuild, and since a rebuild can take about 1 day per 1TB of data that you have on it, i would try to leave the drobo running for at Least 6 days from when it started rebuilding. (possibly a bit more in case you or something else on the computer was accessing data on the drobo too)[hr]
after that, if it still is not working, then there are some more things that can be tried too

I am experiencing a similar issue.I had a drive go bad in slot 2 (flashing red light) I replaced the 1TB drive with a 3TB drive. After I added the drive, The lights flashed for a while until they were solid green. I tried to access my Drobo-FS via the Dashboard, the Dashboard did not see the unit. I powered off the Drobo-FS, waited for the lights to go out, then powered the Drobo-FS back on. The Dashboard recognized the Drobo at first. Then all the lights started flashing yellow and green. At this point I could access my data. The Dashboard would lose the Drobo, then pick it back up. I left the Drobo alone for a couple of days. At this point, all the lights turned green and I could not access my Drobo any more. I pulled my new 3TB drive out to let it configure on the four drives. Same result. It appears that after the data protection is installed, the Drobo goes offline.

I have the new version of Dashboard and the new firmware on my Drobo-FS. I can ping the Drobo. I could sure use some help please, thanks in advance

hi kentenn3, can i check which version you have?
(for example is it the latest version of dashboard for the fs model, such as the one mentioned here) with v2.6.4?

can you see any additional information (in the brief times that dasboard can see the drobo), regarding the drives inside it, such as does it show any extra info or status there? (possibly in another tab or dropdown menu)
in case that is the version, would you be able to try the latest dashboard to see if it makes a difference and for info gathering? for example from here:

I have the exact same problem. I am running dashboard version 2.8.5.
The #4 drive went red one day. I left it in and the unit running and ordered another Seagate 2TB NAS HD to match the other 4 HD’s.
I got the new drive 3 days later. I installed it. All the drive lights started blinking green/yellow.
The dashboard saw the unit and that data protection was in progress. I did not say how long it would take, though maybe I dont know where to look for that.
After about 20 mins of blinking, all drive lights turn constant yellow. I left the unit run for 2 days, I had a little over 3 TB used, so there is more than enough space. I rebooted it because I could hear no drive chatter. Yellow means the drive should be replaced soon. But its saying this for the brand new drive also?

hi trek65000mt, can i check when you say you rebooted it, and its yellow for the new drive, are all of the other drive bays also constantly/solid yellow?[hr]
can you also see the drobo in dashboard after you rebooted it?

[quote=“Paul, post:6, topic:143094”]
hi trek65000mt, can i check when you say you rebooted it, and its yellow for the new drive, are all of the other drive bays also constantly/solid yellow?[hr]

can you also see the drobo in dashboard after you rebooted it?[/quote]

This really sucks, because I can’t stay connected long enough to my array to copy my data over to another drive. I have tried 3 different 2 TB hard drives and the same thing happens with each new drive. I have also put the suspect “bad drive” back into the drobo-fs and then clean booted it. I wait for the drive to red light, and replace it with one of the three working hard drives. The above mentioned outcome is the same each time. Any ideas would be greatly appreciated.

thanks for the clarification and info,
i think at the moment there are probably 4 ways forward…

you could try raising a ticket for the support team (which should still be available as a pay-per-incident in case out of support, if you would wish),

and the other thing you could try would be to try putting your drobo in the readonly mode, for example as mentioned here:
(usually it is for reboot loops, though it does seem as though your unit it trying to start a rebuild process, but then halting as it encounters probably too many errors, and trying readonly mode could help)

the 3rd thing could be linked to the 2 above in the sense that support may be able to advice you if particular drives are having problems and need block cloning, (which support would probably be best placed to help ascertain through diagnostic logs etc, though please do not try to generate any logs yourself just yet, in case that causes problems unless asked for during a certain stage).
If it turns out that some drived need special cloning, there may be a way to recover after that via certain steps.

the 4th thing would also be to try and identify if the drobo chassis is ok (just in case some fault in the hardware is causing the issue, and that a diskpack migration via the migration process may help) - at the moment though, it think it is less likely that the drobo hardware is the issue… but if you wanted to test this out you could try the following:

  • to power all off
  • to unplug all power and cables from the drobo
  • with power still Off and cables unplugged, to remove your diskpack drives (remembering the order for later)
  • to power up the computer and dashboard
  • to connect and power up the empty drobo
    (and to essentially see if dashboard can still find the empty drobo) - however if it asks you about putting drives in, please STOP here…

(you may already be aware, though just to mention that Diskpack drives should only be removed, or inserted, in their entirety, and only with power all Off and cables unplugged)

if you do get in touch with support, please do let them know about this page so that they can be aware of everything, and in case they advise you on certain steps please do follow their steps before mine in case a certain procedure needs to take place.

Paul thank you. I just read your idea’s and will read the article on read-only. I thought I had set this up so it would email me when I had a reply. Sorry for getting back to you late.

Thanks again and fingers crossed!

ah thats ok, sometimes spam filters can block some emails.
ok sure please let us know how things go

Hey Paul, sorry I haven’t gotten back with you. Work has been crazy. I tried everything we spoke of. Spotty connectivity is all I got. Funny thing is now, I replaced the bad drive again. I left the unit alone for several days. I noticed after a few days that all the drive lights were green, but I am unable to connect to it. Even after several reboots of the unit. Each time the lights are all green but no connectivity.

hi thats ok, time tends to fly by when people are having fun (but also when there is work to be done) :slight_smile:

thanks for trying out the suggestions on page 1… for the drive you replaced, can i check if you had finished the test and came out of readonly mode again?
having green lights is usually a good sign, though can you remember or check to see if the drives and unit are making chattering (usage) noises and vibrations etc? for example maybe it is verifying some data in the background?

in case it is, then maybe giving it say 3-4 days could be a good idea before we try something else? (i say 3-4 bearing in mind that a data protection / relayout / rebuild could take about 1 day per 1TB of data and tend to use that as a minimum baseline, though a little bit more could help, especially if there is drive chatter)