Drobo FS Failure - Total Loss

I have a Drobo FS originally with 5 X 2 TB drives. After years with no issues, I ran out of space and began replacing the 2TB drives with 4TB drives. I did this 3 times successfully letting Drobo repair itself in between. When I tried to replace the 4th drive, all lights went red. Even putting the original 4th drive back in did not fix the issue. After working with Drobo support for months, the issues still exists. The last thing I attempted was to clone all the drives that were in the Drobo when it was working last. I put them into the Drobo and all lights went green and Drobo started the repair process. When the process was complete, I got a mount failure error. The status of the Drobo says 75% used and 100% free which makes no sense. I did a Dashboard repair. No difference. Now that I have the clones, does anyone have any ideas on what I can try? Does anyone know any recovery software that can work with BeyondRAID with mismatched drives? What ever I do, I would have to mount the drives individually. Help?

I hope the best in that situation, great idea about the cloning.

I’ve used Drive Rescue on a mac successfully a couple times, be ready to work on this project for like a week with all those TBs though. Best of luck and let us know how it turns out.