Drobo

Drobo FS Disk Drive Spin Down not functional (#10-097)?

Chris,

Drobo v2 on DroboShare does spin down the drives. Back when I used DroboShare, they spun down and it was noticeable because on the next access there would be a slight delay for them to spin back up.

That’s why there’s the Insomnia DroboApp. :slight_smile:

It’s really not much help as a “standby” mode if the only way to wake it is to turn the power off then on. Seems more like being “OFF” to me…

My latest update from support sounded as if a fix to the FS spin down issue may be coming soon. They didn’t promise a release date but the message gives me the impression they may have the fix in testing and if it pans out it would be released soon.

@Spiney: True, in Drobo vernacular, “Standby” is pretty much “Off” for lay-people.

Here is the response I received from my question regarding the status of this issue:

"I apologize for the inconvenience you are experiencing. We have no ETA on this fix, however our engineers are very aware of this issue and working to resolve this as we speak. When this issue is resolved, it will be posted on http://www.drobo.com/support/updates.php."

Looks like we will be living with this for a while longer.

Good news…firmware FS 1.0.5 was just released and lists that it fixes the spin down issue.

Edit: I had to manually update to this firmware, most likely due to internet connection issues when downloaded the update. I’m not seeing any difference in drive spinning. I went as far to wait 30 minutes and ejected a drive to verify that it was in fact still spinning.

I’m curious if anyone who had the spin down issue sees that this fixes it?

Just upgraded mine, but still copying data, so I haven’t tested the spin down. I update as soon as I can.

Update: Mine spins down just fine after the upgrade

No change. My drobo still doesn’t spin down anything. Even the fan is constantly running at the same speed.

@fotolli, Try rebooting your FS.

rebooting didn’t have any impact on the fan or disks. After sitting over night, the disks were still spinning. I unplugged the network cable and after 15 minutes the disks stopped.

Please open a support case then.

If it worked as expected with the network unplugged, it sounds like something is accessing your Drobo across the network.

Speaking as someone who takes and interprets network traces for a living, there are a lot of things happening on a network that users don’t know about. For example, if a machine has a network volume mounted, there may be some process on that machine that’s scanning the network volume every so often (Anti-virus, a PnP video/music sharing program like FireFly, spotlight on a Mac, or a similar indexing program on Windows, etc.).

People who have this problem even after disconnecting the network could have a misbehaving Drobo App.

If you are technically inclined and happen to have the hardware, you might try hooking up a hub (not a switch!) between the Drobo-FS and the rest of the network, then hooking up a machine to trace with on that hub and taking a trace with wireshark (free download). Wireshark does a pretty good job of showing you what type of traffic is going on. If you see any SMB traffic destined to the Drobo-FS, then that’s probably your problem.

It’s important to use a hub, because then you’ll see all the traffic to/from the Drobo-FS. If you use a switch, you’ll only see traffic from your tracing machine.

An alternate way of testing this out would be to unplug one device from your network at a time, then waiting 15 minutes to see if the drives spin down. If they don’t, unplug the next device (leaving the 1st unplugged), repeating the process until the drives spin down. The last device you unplugged is probably the one using the Drobo-FS. This method is more time consuming and error prone, but might yield an answer if you are patient.

thanks for all the tips and I have tried to eliminate as much as easily possible when I tested.

I ruled out drobo apps by disabling ALL of them (except dropbear) in the .servicerc file before restarting and I completely powered off my media player to be sure that wasn’t doing anything strange.

After more testing it today, it’s looking like the XP workstation with Drobo Dashboard running is causing it. I’ve shutdown that workstation and the drobo is fine plugged into the network for hours but then after booting back up and waiting 30 or so minutes, the drobo disks just start up. the only thing accessing the drobo is it’s dashboard.

I’ve taken diags from the drobo after 45 minutes of spinning and then again after unplugging the network and letting the disks stop spinning. I’m waiting for support to analyze these and provide feedback now.

I just received this reply from support that is rather discouraging after almost 3 months of waiting and complaining.

I don’t think they really fixed the issue and now it sounds like the failure to spin down is now a “design feature” of a poorly designed NAS product. Has they kept explicitly listed this as a feature from the beginning I would have returned it. Anyone who is still having this issue, if you haven’t already opened a case with support, I urge you to do so immediately so that DRI knows that this is still an issue.

Edit: I forgot to mention that I reinstalled the lastest firmware again and rebooted twice hoping it might help. I unplugged the network cable from my FS last night before going to sleep and go figure, the drives are STILL spinning today so I guess unplugging the network cable doesn’t always work either.

After a long weekend of testing my Drobo FS, I’ve isolated my issue to the SMB traffic from the local computer browser running on Windows XP Pro SP3. This exact same traffic does not cause the disks to spin up on my DLink NAS but causes the disks to never spin down on my Drobo FS.

One workaround was to use a different workgroup setting than the rest of my network which causes other network browser services to ignore the drobo but this also causes my media player to ignore the drobo file share and is a less than perfect work around.

For anyone else that is still having this spin down issue, try changing your network workgroup and see if this makes a difference. Also, I’m curious if anyone else having this issue is NOT using any windows computers on their network?

Did several restart, cold boot, et al, STILL NO SPIN DOWN!

What gives . . . Any hint or more information you need to resolve this issue?

I have 3 computers on the net, and even when all 3 are asleep OR SHUT OFF, the Drobo FS still does not spin down… the Droboshare worked as specified on the techical data sheet, and spun down. The FS is not within specifications.

@equifoto@embarqmail.com, have you opened a support case?

I found what was causing my issue and it could potentially be causing the issue for others as well. The Drobo FS stores the “connections.tdb” file for Samba on the physical disk so any anonymous connections ALWAYS causes the drives to spin up regardless if anything on the disk was actually requested through a share.

I fixed this by changing the path where Samba stores the non-persistent files. Since the smb.conf file is generated, I edited /etc/.backup_smb.conf to override the smb.conf setting by adding the following:

; store samba lock files on flash under /var (only 2MB total)
;lock dir = /var/samba/lock
; or store them in memory instead of persistent storage
;lock dir = /dev/shm/smblock

After over two months, my Drobo finally spins down as expected. The fan still runs, but it’s much quieter.

Edit: Warning: The /var mount is only 2MB total, so this could potentially cause issues if the lock files start growing too large. Updated example config showing an alternative to use virtual memory.

Yes I did… still very confused by this ‘black box’ with no user dialogue.

How do I know when it has spun down? Special light color?

I’m doing a suggested test now, over the next 24+ hours.

No, there is no special light color, shade, or flashing.

Depending on the type of drives you have, you should be able to hear that the drives are still spinning even with slower drives. If you can’t really hear any difference, simply take the front cover off your drobo and feel the front of your drives for heat. If your drives are spinning, the drives will feel warm. After the drives spin down, the fan should make the drives feel cool within a few minutes.