Drobo FS - Client Machines Mounting As Read-Only

Hey gang,

My Drobo FS is misbehaving.

The Drobo filesystem is mounting as read-write (rw), however, client machines are mounting as read-only (ro). I’ve tried Mac OS X and Windows 7 as well as AFP and CIFS.

From Drobo:

$ df -h /dev/sda1
Filesystem Size Used Available Use% Mounted on
/dev/sda1 16.0T 8.1T 7.8T 51% /mnt/DroboFS

$ mount |grep sda1
/dev/sda1 on /mnt/DroboFS type ext3 ([size=large]rw[/size],noatime,nodiratime,data=ordered)

From Mac laptop:

Using a manual SMB mount:

//GUEST:@ on /Volumes/Public (smbfs, nodev, nosuid, [size=large]read-only[/size], noowners, mounted by t1882mh)

Auto-mount as AFP:

//;AUTH=No%20User%20Authent@NCNAS._afpovertcp._tcp.local/Public on /Volumes/Public-1 (afpfs, nodev, nosuid, [size=large]read-only[/size], mounted by t1882mh)

I’ve tried manually mounting/unmount from the client machines as well as powering off/on the Drobo (gracefully shutdown via Drobo Dashboard and then physically hit the power switch).

I’ve used this Drobo for a few years and haven’t made any recent changes (that I can think of ).

Any tips for troubleshooting why client machines are only mounting as read-only, not read-write?