Drobo

Drobo FS Apps

Hey there

I just bought a Drobo FS as replacement of my prior Western Digital and I’m only happy about it.

I started updating it and installing serveral Apps like WOL from the DroboAdmin Utility. And I see that they all are installed correctly according to http://192.168.0.94:8080/droboadmin/ and tho Drobo folder for Apps.

My issue is that I can’t find anywhere to launche the apps I’ve installed. I’ve been thru all my Drobo and my pc.

I can’t use the apps if I’m not able to open them!

I already did the RTFM and checked the Internet including the threads in this forum.

Damn it!

  • Andy

Many of the DroboApps run from the command-line, so you should install the Dropbear SSH DroboApp and install an SSH client like PuTTY on your computer to connect to it.

Thank you for your help.

I now installed the PuTTY and I think I reached the Drobo by what you call the command-line. I logged in as root with the password root.

How do work it from here? It looks its waiting for commands and I don’t know any but a few dos-commands. Are all the setup supposed to be handled with commands from PuTTY?

I so, do any know a guideline for me to learn the basics?

Thanks again!

I have a related question:

What seems to be the best/easiest way to access files residing on Drobo FS remotely?

Via Pure-ftpd?

@Andy: It’s embedded Linux, so close to DOS, but a little more raw. :slight_smile:
Really depends on what the application you’re using needs. Most times you just need to edit a configuration file.
I haven’t used the WOL app myself, but I would guess that it requires a few parameters. Try just typing ‘wol’ (without quotes) at the prompt and see if that gives you further info.

@CannibalTree: Pure FTPd, or SMB via SSH tunnel, if that’s more your style.

I feel I’m getting closer for each post you write, bhiga. It just says “-sh: wol: not found”.

Which Apps have you installed. If I knew how to get one running I might be able to do the next on my own. The ftp and torrent app is among others I like to use.

According to the source package it seems it’s called etherwake but there doesn’t seem to be documentation there. One significant difference between DOS and Linux - Linux stuff generally assumes a higher level of understanding… There’s no "HELP " like in DOS… well, if you come from DOS 2.x like me, there wasn’t either, hehe.

Try etherwake or ether-wake and see if that gets you something.

there isn’t a hell of a lot you can do from the command line. the drobo is meant to be accessed over the network, and managed with the drobo app. if you don’t know linux, you’d be better off just staying out of it and disabling command-line access so someone else can’t get in. it is possible to screw up your drobo entirely, get access to protected files, or remote anything and everything through the command line with root access.

if you really want to learn the unix command line i’d strongly recommend installing a user-friendly distro like ubuntu on a system you have and learning there. the drobo embedded environment is not the environment you want to learn linux on. it’s not a full distribution and doesn’t contain everything you’d find elsewhere.

take it from someone who’s been using unix 31 years…

I see your point scottjl even though I normally feel quite confident controlling network thru dos. You say that the drobo is meant be managed with the drobo apps. But the thing is I can’t find a way to start the apps even that’s what I want the most. This is why bhiga tried to help me open the apps.

I need to run the ftp, wol and torrent app

I have the same ‘issue’ with DroboApps although I’ve got more than 10 years of experience with Linux I would like to use the Drobo under Windows, don’t want to start Linux on my Windows 7 laptop just to look at files on my Drobo for 10 sec.

@graviton: Not sure what you’re saying here? Your Win7 machine should be able to access the Drobo FS as an SMB/CIFS client.

I have had similar issues with trying to access and copy my Drobo FS files remotely. I was able to configure Dropbear and access via Putty and then with the more user friendly WinSCP program. I was able to look at the files on the Drobo (at least locally on my Home network), unfortunately I have been unable to copy the files to me computer from Drobo using the SCP protocol. It appears that SFTP is a better protocol, but that Dropbear doesn’t have this capability.

I had issues connecting to Drobo back then under Windows, but on Linux it worked (not via Drobo-Utils).