Drobo

Drobo Elite and open iscsi

Hi,

After login in my 4T iscsi lun from drobo elite, I can’t mkfs.ext3 nor pvcreate nor cat /dev/zero > /dev/device.

I tried with and without multipath

While I’m cat I can see:

Jun 23 16:27:21 sprdom kernel: [3551854.655583] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
Jun 23 16:27:21 sprdom kernel: [3551854.655649] end_request: I/O error, dev sde, sector 0
Jun 23 16:27:21 sprdom kernel: [3551854.655682] __ratelimit: 270096 messages suppressed
Jun 23 16:27:21 sprdom kernel: [3551854.655716] Buffer I/O error on device sde, logical block 0
Jun 23 16:27:21 sprdom kernel: [3551854.655754] Buffer I/O error on device sde, logical block 1
Jun 23 16:27:21 sprdom kernel: [3551854.655819] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
Jun 23 16:27:21 sprdom kernel: [3551854.655885] end_request: I/O error, dev sde, sector 0
Jun 23 16:27:21 sprdom kernel: [3551854.655969] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
Jun 23 16:27:21 sprdom kernel: [3551854.656026] end_request: I/O error, dev sde, sector 8589934584
Jun 23 16:27:21 sprdom kernel: [3551854.656084] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
Jun 23 16:27:21 sprdom kernel: [3551854.656139] end_request: I/O error, dev sde, sector 8589934584
Jun 23 16:27:21 sprdom kernel: [3551854.656279] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
Jun 23 16:27:21 sprdom kernel: [3551854.656339] end_request: I/O error, dev sde, sector 0
Jun 23 16:27:21 sprdom kernel: [3551854.656400] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
Jun 23 16:27:21 sprdom kernel: [3551854.656457] end_request: I/O error, dev sde, sector 0
Jun 23 16:27:24 sprdom iscsid: connect failed (111)
Jun 23 16:27:28 sprdom iscsid: connect failed (111)
Jun 23 16:27:28 sprdom kernel: [3551862.339446] sd 4:0:0:0: [sde] READ CAPACITY failed
Jun 23 16:27:28 sprdom kernel: [3551862.339469] sd 4:0:0:0: [sde] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK

After rescan:
Jun 23 16:27:28 sprdom kernel: [3551862.339469] sd 4:0:0:0: [sde] Sense not available.
Jun 23 16:27:28 sprdom kernel: [3551862.339469] sd 4:0:0:0: [sde] Write Protect is off
Jun 23 16:27:28 sprdom kernel: [3551862.339469] sd 4:0:0:0: [sde] Mode Sense: 00 00 00 00
Jun 23 16:27:28 sprdom kernel: [3551862.339469] sd 4:0:0:0: [sde] Asking for cache data failed
Jun 23 16:27:28 sprdom kernel: [3551862.339469] sd 4:0:0:0: [sde] Assuming drive cache: write through
Jun 23 16:27:32 sprdom iscsid: connect failed (111)
Jun 23 16:27:36 sprdom iscsid: connect failed (111)
Jun 23 16:27:39 sprdom iscsid: connect failed (111)
Jun 23 16:27:43 sprdom iscsid: connect failed (111)
Jun 23 16:27:48 sprdom iscsid: connection5:0 is operational after recovery (31 attempts)

This drobo elite has 2 disk presented. One to windows and one to linux.

When I tried to pvcreate device errors from windows appeared, and it disconnected from drobo

How can I solve this issue ? It is possible have such config ?

Thanks !

Well now without playing with open-iscsi, only turning on drobo elite these messages are showed to me:

W 07/12/10 10:03:15 00331 FFI: port B12-High collision or drop rate. See help.
I 07/12/10 10:01:33 00076 ports: port B12 is now on-line
I 07/12/10 10:01:31 00435 ports: port B12 is Blocked by STP

If I connect one cable to one switch and another to another switch one tell me about STP block, and another about LACP block:
I 07/12/10 11:04:51 ports: port 17 is now on-line
I 07/12/10 11:04:48 ports: port 17 is Blocked by LACP

No need to launch any command, I can’t ping drobo anymore :(. I tried changing drobo networking but I can’t get it working again :frowning:

Sounds like there’s either an IP conflict or a loop in your network.

Can you detail your network topology?