Drobo

Drobo eating up 100% of a core at boot, preventing shutdown, and no Drobo Dashboard

I’ve got an old Drobo 1st generation that connects via USB. It has four drives in it 2x320GB (Western Digital) and 2x1TB (Seagate) and is running the latest firmware (1.3.7). It is formatted NTFS (no XP support) for connection to a host machine that runs Windows 7 Ultimate x64, Athlon x2 4400, 2GB ram.

First, the backstory. I’ve purchased the Drobo in September 2008. In October 2008 I had the unit replaced because of a fan failure. In spring 2009 (don’t remember the exact date) I had the unit replaced because a diagnostic log showed something wrong with the machine and the writes were extremely slow (1MB/s). From September 2008 to April 2010 it was connected to Linux machine, formatted as ext2, and stayed on 100% of the time, although it was rarely accessed. It was primarily used as a storage location for some offsite backups.

In April 2010 I changed my machines around and plugged it into Windows 7 Ultimate machine. This machine is not on 100% of the time, although it usually wakes up automatically a couple of times a day to record programs for Windows Media center. After recording it goes back to sleep. The Drobo’s primary use is as storage for backups, which are also replicated offsite. When I moved the Drobo over I formatted it as a 16TB volume.

About a month ago I found that my Drobo was taking a long time to start up, and some digging found that it might be because when I installed Windows 7 on the machine I was eager to use the Windows 7 backup tools, so I used them. Apparently that’s a no-no and I had now jacked up my Drobo. I recovered by copying everything off the Drobo and reformatting the Drobo and also disabling windows built in Backup. I still needed some sort of backup, so I installed CrashPlan as it lets me mirror backups to remote systems too.

Ever since this happened my Drobo has been utter rubbish. When I start the machine it takes 100% of one of the processor cores and must be saturating the system calls (the usage is in System, I can’t dig much further than that other than see that there is a kernel thread that is taking up all of the time. During this time the Drobo is also churning and the entire system is essentially unusable.

After a long time (I’ve had to wait 26 hours for this, generally about 6 hours) the Drobo eventually shows up in Explorer, but without a drive size. The system becomes usable, I can browse the files, CrashPlan can save files, and stuff is generally ok. However, Dashboard does not show up and fails to recognize I have a drive connected. When the machine goes to sleep once and wakes up again it will be fine for a little bit, then DDService.exe will start to mimic the same thing that System did on startup. It takes up 100% of a core, makes tons of system calls, and generally makes the machine unusable – however the drives aren’t going crazy like when System was whacking the drives on bootup. Furthermore, if I attempt to shut down the machine or logoff while DDService is doing it’s thing, I’m in the same scenario as boot up – as of right now I’ve been waiting for 16 hours for the machine to shut down.

I’d love to follow some of their instructions and shut the machine down by telling Drobo to shutdown first, but DroboDashboard doesn’t start. This also eliminates my ability to pull down a diagnostic file.

So, any idea of what I can do to fix this? It’s a long process to copy the data to other drives and reformat, so before I blindly go reformatting I thought I’d ask for any help other people can provide on slaying this beast.

EDIT 9/26/2010 21:20 UTC: On the rare occasion that Drobo Dashboard does appear and work, attempting to place the Drobo in standby results in System eating up 50% of the CPU for hours on end without any disk activity. The Thread that eats all of the CPU time is listed as ntoskrnl.exe/KdPolBreakIn.

EDIT 9/27/2010 05:54 UTC: Just had a very strange event with the Drobo after it finally started. I was compressing a few folders on it and the Drobo froze. The disk activity light was flickering the whole time, indicating it was doing something, but I didn’t hear much disk activity. During the 30 minutes it was hung like this DDService.exe was taking 100% of a core. Process Explorer says it was stuck in ntdll.dll|RtlUserThreadStart.

Please open a support case.

This EXACT same behavior is happenning to me. I am also on a Win 7 Ultimate N box (not AMD though).

I have moved the Drobo to another computer and the behavior follows the drobo so it is definitely the Drobo itself. Even with all the drives removed it pins the kernel (not the idle process but the actual NT kernel “System” process) and the machine is unusable.

After 3 calls so far (and a heck of a lot of elevator music on hold time) support has not come up with any solutions and seems to not want to replace it. They just keep asking me to do things I have already tried.

Did you ever get this solved? What was the resolution?

Thanks

@SchnauzerBot, have you used Win 7 Back Up Utility on the Drobo?

No. I use Yadis Backup

I was coming in here hoping for help as i have still had no response from support (4 days on) on a similar issue with Windows 7. It is a known issue with a KB article on the drobo site saying dont use Windows 7 backup as it can mark the drobo as bad then Win7 runs like a dog. The KB article goes on to say just copy the data off the drobo (the same one that wont mount as it locks the PC’s and Laptops up) and format the drobo then copy the data back. It offers no real solution for the problem saying wait until Microsoft fix it.

What i cant believe is no where on the site does it say DONT use Windows 7 backup with the drobo as it will kill it. You only get that advice after the event. Maybe an alert on the dashboard or something would of been nice.

Surely the claims of Win 7 compatibility are a wrong too with issues like this.

Anyway end of rant! Any help would be appreciated.