Drobo disks not readable by this computer

I have a Drobo S with 5 volumes. Three of the volumes can be read, no problem. Two of the volumes now show that they are not formatted, even though I know one of them has data on it and was working properly up until four days ago. I need help fixing the problem. The data is important and represents about 15 months worth of work product.

Pertinents:

Mac OS X 10.11 - upgraded to El Capitan on 10/1/2015. Drives were working fine until 10/7/2015. After discovering the problem, I followed instructions regarding the firewall options, uninstalled Drobo Dashboard. Reinstalled Drobo Dashboard, then upgraded the Dashboard to 2.6.4. No change to drive status

Drobo S - 5 volumes
Volume 0 - shows up just fine - 2TB HDD
Volume 1 - shows up just fine - 2TB HDD
Volume 2 - Not Formatted - 2 TB HDD
Volume 3 - shows up just fine - 2TB HDD (* note - this actually a 3TB HDD. Under Status, it shows capacity as 3TB)
Volume 4 - Not Formatted - 2TB HDD (* note - this is actually a 3TB HDD. Under Status, it shows capacity as 3TB. This was my check disk volume)

I’m on a 27" iMac that I bout new in March 2015.

Let me know if you need any info to help with a response. I really can’t afford to lose the data in Volume 2. I do have the original 2TB HDD that I used as a check disk before I replaced it with the 3TB HDD a couple of months ago.

Any help would really be appreciated.

I think you don’t understand how Drobos work.

The volumes have no relation to the disks AT ALL.

Thikn of a “volume” as a big container for your data… each of those is spread all over all of your disks…

equating volume 3 to your 3tb hard disk is nonsense… volume 3’s data is spread (probably pretty equally) over all of the physical disks in your drobo.

If nothing else that means that the disk you removed is totally useless, as the bits of data on it… no longer correspond to the rest of the bits of data on the other 4 drives you left in your drobo.

When you say volume 4- this weas my check disk volume - what do you mean by check disk volume?

Is there a way to add a screen shot? The information I typed is what I see when I click on “Volumes” in the Drobo Dashboard.

I am not a tech savvy person, so my apologies if I’m not communicating very well what the problem is. I’m a photographer, and I use the Drobo to store my archives. Let me try again.

I have the data on 5 drives broken into 4 volumes that essentially correspond to years. Volumes 0, 1, and 3 show up in Finder, and I can view and manipulate the data in those volumes. Volume 2 gives me an error that says “This drive is not readable by this device” and then I get the option to “Format” or “Ignore”. I click Ignore and then open the Drobo Dashboard. The Dashboard shows what I posted above. I never created a 5th volume (Volume 4), but it also creates the same error when I plug the Drobo into my Mac.

The data on Volume 2 represents the last 15 months of my work product, and I need to get it back. How do I do that?

I would love to chat with somebody in person. I can post screen shots. This is very important to me, but because I’m on a legacy product, Drobo’s support line will not help me.

Thanks.

Very interesting. If I am understanding correctly, then only one volume is not mounting and Drobo Dashboard is reporting the volume is not mounting.

If you open Disk Utility, is the volume grayed out (I suspect so, as the volume is not mounting).

Sounds to me like file system corruption. Have we tried a repair disk on the volume?

https://myproducts.drobo.com/article/AA-01803

In Disk Utility:

It shows USB 3.0 Drobo S then has what looks like a sub folder with the name of the volume and an “eject” button. The three working volumes are there. The volume that isn’t working shows up, but just says “USB 3.0 Drob S - Gen 2 Media 2.2TB Uninitialized” and has no eject button. I also have the following table:

Location: External
Connection: USB
Partition Map: Not Supported
S.M.A.R.T. Status: Not supported
Capacity: 2.2TB
Child Count: 0
Type: Disk
Device: disk7

I have the option for First Aid, Erase, and Info

I clicked on First Aid, and clicked Run. It immediately returns a result that says “Done” and shows “Operation Successful” in the “Show Details” and nothing changes.

hi steve, just a quick note about screenshots,

an easy way could be to take the screenshots locally, such as of all the tabs and windows of dashboard info, and of your apple tools process, and to then simply upload them them to imgur and to post the links here. (please be careful to rub out any sensitive info like your serial number before uploading though)

there is another tool for checking mac volumes which i think is more powerful than disk util which is called disk warrior, but its good to not click on any format or erase options at all. (only dashboard should be used for that and only for specific purposes though)

okay. I’ve been able to scan the drive, and the files are there, so the data exists, but I can’t get the volume to mount or access the data through Finder. I think that the problem might be that the file allocation table has become corrupted. The volume was in NTFS format, if that helps.

Is there a way to recover the file allocation table? I think that would solve my problem.

hi, can i check was that drobo originally setup on a windows computer?
maybe you could try to plug it into a windows machine, and then if drive letters appear for it you could try running a chkdsk on it?

Yes - it was originally connected to a Windows 7 computer that crashed and burned. I replaced it with my current Mac and have been slowly migrating everything to HSF formatted disks as time and funding allows. This was actually the next volume I was going to migrate over. I don’t have a windows PC, but I’m sure I’ve got a few friends who do. I’m cloning the drives right now just in case I screw it up, so once that’s done I’ll follow your suggestion and report back.

ok thanks for the update steve,
if you can end up accessing your data when at your friends house (and if you dont have any problems with it e.g. the data is ok, then id recommend making some backups of the actual data, if possible, even if you have already cloned the drives).

if you still can not access things properly, then you may as well try the chkdsks.
(you may already know how, but just to mention…)

for each volume (driver letter) that you have in windows for the drobo, and only 1 at a time, (assuming E is your drobo letter), then please try the following:

chkdsk e:
(see if it mentioned any problems, and then try the following when finished back at the command prompt)

chkdsk e: /x
(this will run it in fix mode, and ideally will say at the end, something about no problems being found, if it does not do that, then at the end, try chkdsk e: /x again)

after a few iterations, it should hopefully give you that message, and then you can try to access your data.