Drobo Dashboard won't show up Drobo 5D

So all of the sudden my Drobo 5D disappeared of Dashboard and noticed that my all the lights in the drobo were off except for the power light (green), at this point my drobo has 4 Hard drive and 1 empty bay and using widnows 7 pro 64 bits and USB3.0. So I tried the following:

  • Reboot Drobo manually by pressing the button in the back and letting it shut down, then powered it up.
  • During the powering up all the lights where lighting up as usual but then all of the sudden it shuts down and except for the power light stays on but goes from green to yellow.
  • On the Dashboard the drobo is not showing, but a message will pop up saying: Drobo:NAMEOFDROBO -> Degraded with no extra drive, do not remove any drive.
  • The day before this happened I got pop up message saying to replace a hard drive and another popup message saying that I was in critical low space. After seeing that my drobo was in this state went and bought another hard drive and inserted in the empty bay. Then shut it down by pressing the button in the back again.
  • Power it up again and still the same message and drobo showing in my dashboard.
  • Updated the drobo dashboard to the latest version and nothing.
  • Rebooted the computer, nothing, still not showing.
  • Shut the drobo off again, remove data cable, power up the drobo, reboot pc, plug the data cable (usb3.0) after machine has rebooted. No show and the lights in drobo all of except for yellow power light, keep getting the message: Drobo:NAMEOFDROBO -> Degraded with no extra drive, do not remove any drive.
  • Bought another drive to replace the one that was lighting up red and when I did that and rebooted the drobo and I saw the drobo in the dashboard but with a different name and with an error saying that I needed to put back the drive that was removed, and beside this all the hard drive status lights where red. So put back the bad/old drive again and went back to the same situation.
  • I noticed that my drobo doesn’t have the latest firmware but I cant updated to the newer one because I don’t see it in the dashboard.

I am out of ideas, not sure what to do.
Please some one help!!!
Very much appreciated.