Drobo

Drobo Dashboard Won't Minimise To System Tray

Not sure why, but no matter why I do, Drobo Dashboard won’t minimise to the system tray. As a result I can’t access Drobo Copy. Is there any particular reason for this? I’m running Windows 7 64-bit

It did work at one point (as I setup some Drobo Copy tasks) and the tasks still run, but I can longer make any changes. I’m running the lastest Drobo Dashboard.

  • Josh

Very strange. What version of Drobo Dashboard? (“latest” is variable g)

With my Drobo Dashboard opened, I am still able to right click on the pie icon in the system tray.

Have you tried rebooting your computer?

Reinstalled different versions, rebooted, and no pie icon. I even attempted to remove all registry related keys and user data files relating to drobo, but still no pie icon. I did reboot and still nothing. When dashboard starts, there is no icon showing not connected.

It did work for the longest time so I’m not sure at what point it stopped showing. Without the pie icon I can’t quit the program (have to kill via Task Manager) nor updata drobo copy.

I’m running Drobo Dashboard 1.73 on Windows 7 x64.

  • J

You’ve clicked the little upward-facing triangle to ensure it’s not just being auto-hidden by Windows, right?

Also, if you have or once had multiple monitors, it might be opening the window off-screen.

Once Drobo Dashboard launches and you see it on the taskbar, hit Alt-Space, M, then hold the Left Arrow key until you see the window frame.

It’s definitely not hidden :slight_smile: Even showing all icons in the taskbar doesn’t show anything. Drobo Dashboard doesn’t show up on the taskbar when “closing”, only when minimise. But that doesn’t help because without the notification icon I am unable to access the other menu options. I don’t think Dashboard is even creating the system tray icon because even killing Explorer and re-running it won’t create the system tray icon. Sounds strange I know, but no other program elicits this behaviour so it seems to be Dashboard related.

Does it show up in the list if you right-click the tray area and select Customize Notifications?

Have you tried uninstalling and reinstalling dashboard?

Yes, tried install, reinstalling, even older versions. There is no icon in the notifications so there is nothing to set like display always. As mentioned before, when it starts up, I seem to remember there was an icon in the try before the pie, but there is nothing at all. When I “close” the Dashboard, it just disappears. I can see it is still running in TaskMan, and double-clicking the Dashboard icon brings it up, but it’s really strange how there is no icon. Is there any way I can disable the DroboCopy so I can look for another solution?

Truly Bizarre . . .

I honestly have NEVER seen this behavior before.

Can you try a different computer?

Right-click the little upward facing triangle and select Customize notification icons. Otherwise you’d never be able to bring anything back if you hid all your tray icons. :slight_smile:

I have an update. It seems whatever is preventing Drobo Dashboard from showing the icon is preventing firmware updates. I’m getting the following errors in the event log:

System.InvalidOperationException: Invoke or BeginInvoke cannot be called on a control until the window handle has been created.
at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
at HostUser._HUA._ESAUpdated(_HUA* , ESA* pESA)

System.NullReferenceException: Object reference not set to an instance of an object.
at HostUser.DynamicIcon.set_Text(String pValue)
at HostUser.HUA.Update()

Perhaps the developers can shed some light on this?

Are you running in some kind of limited-permissions account?

Also, any pending Windows Updates? Especially .NET Framework 1.x, 2.x, 3.x updates?

No and no. System is always up to date and account is not limited. I even tried run with admin with no success.

Judging by the error messages, something’s preventing the window from being created. Any antivirus/antimalware/etc?

Just Microsoft Security Essentials. Tried installing Drobo Dashboard on a virtual 2008 server (with Security Essentials) and oddly Drobo Dashboard came up properly (and I was able to upgrade the firmware).

Wonder what it is about my system that is causing these problems . . . ?

Really not sure… It seems like something essential is either disabled or didn’t get installed OS-wise.

Was this a fresh install you did on your own, or was it something preinstalled? I’ve seen rare cases in the past where OEM-preinstalled Windows versions were missing essential driver components (namely Firewire, which made the system ask for a 61883-class driver or something like that).

If you really need it to work on this particular machine, I’d try a Repair install of Windows, or do a fresh Windows install. At least Win 7 doesn’t take as long to install as its predecessors.

I actually was able to solve it. Strange. I looked at the Event Log and the following clued me in:

System.ArgumentException: Font ‘Segoe UI’ does not support style ‘Bold’.
at System.Drawing.Font.CreateNativeFont()
at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
at System.Drawing.Font…ctor(Font prototype, FontStyle newStyle)
at HostUser.HUA.InitializeTrayIcon()

I looked at my Segoe fonts and not all were registered. Two were missing (including Bold). I copied them to my Desktop and dragged then into the Font directory, not replacing the ones that existed. Two got registered. I re-ran Drobo Dashboard and all is well.

Wierd or what?