Drobo

Drobo Dashboard reports no new firmware available - yet there is.

Having been a member of the “small number of situations” with “shit” performance on our DroboPro, I’ve been keen to move to the new 1.1.4 firmware. The day it was released I opened up Drobo Dashboard and clicked ‘Check for Updates’ thinking it would do that - but it reported that I was running the newest version of the Dash and Firmware (the Dash is @ 1.6.6 but the fw 1.1.3).
Today I’ve tried it again - still it thinks I’m up to date.

I tried to download the firmware manually but the linked DMG file contains a single .tdz file with no additional information inside. The release notes, although thorough, don’t explain how to manually update or even use the file.

Also why was there no mention of the update on the RSS feed for support? Dash 1.6.6 and just recently the Elites first update have been listed but no Pro 1.1.4.

1.1.4 is not an auto-update yet. So dashboard will not see that new firmware.

I show the following in my RSS feed and from the RSS feed located on the right side of our webpage:
Data Robotics, Inc. has released firmware version 1.1.4 for the DroboPro.

On the top of the software updates page is this:
Additional support documentation is also available.

Where the word “documentation” is the link for the pdf listed below.

Instructions for Manual Firmware Upgrades:
http://www.drobo.com/pdf/ManualFirmwareUpgradeInstructions.pdf

Ahhh, I assumed once you released it publicly on one place it would be the same everywhere. Now I know. Thanks.

As for the RSS thing - this is what I currently see in Firefox (no mention of 1.1.4).

[quote=“Jennifer, post:2, topic:935”]
1.1.4 is not an auto-update yet. So dashboard will not see that new firmware. [/quote]

Why do you guys do this?

And why do you use FTP for the Dashboard updates? Some places, like my job, block FTP. Why can’t it just be an http link since that’s what the website uses as well?

it could be any number of reasons, perhaps one basically comes down to the fact that it probably makes sense to test it on a smaller group of users who are possibly more technically minded (manually downloading and installing updates), before pushing it out automatically to the whole installed user base.

And now like magic, the RSS feed is correctly listing updates again.

Yes, it was fixed.