Drobo Dashboard Can't Find, Mac Finder Can

Hi -

I’m struggling with something that I think must have an easy fix and could use some guidance.

  • I’m running Drobo Dashboard v2.8.1

  • OSX El Capitan v10.11.5 on a iMac Retina 5K (mid-2015)

  • Drobo Dashboard is unable to find my Drobo 5N

  • I’m able to mount/read/write to my shares using the Finder application

  • DDService64d is set to “allow incoming connections”

Please help!


hi shawn it’s good that you are able to access the data.

can i check if dashboard was able to find the drobo before, (and that it recently stopped)?
if it did recently stop, can you remember any changes that possibly took place since then, such as an update to software or to the connection process in some way?

Hi Paul - Sorry I’m just seeing this…I was expecting a notification to let me know there was a reply and I never got one.

I have never been able to access via Drobo Dashboard with this iMac. I previously could with a Macbook Pro that I no longer own.

I did get a new modem from my cable company, but I can’t remember if this problem came before or after the new modem.


Just found this answer online. Worked for me.

Starting with Lion (OS X 10.7) Firewall, it is very likely that the Drobo Dashboard (along with DDserviced, DDservice6d4) have not been set so as to allow incoming connections.


thanks for more info shawn,
and as shalldor kindly mentions, does checking the permissions and firewall settings help you at all?

it might also be worth trying to plug in your 5n directly to your computer (without going through a modem router, in case that is how is is currently connected), just to see if it makes any difference?

Hi Paul - As mentioned in my original post (way back, I know), DDService64d is set to allow incoming connections. I can’t find DDserviced appearing anywhere though…


hi shawn, thanks for more info,
maybe you can try that direct connection (just as a test), and then if there are still problems, maybe a different cable, plus to uninstall, and reinstall drobo dashboard could help?

here are some links for you for software and dashboard:

Paul -

I took these steps:

  1. I connected directly to my iMac via ethernet
  2. I reinstalled the latest version of Drobo Dashboard


  • Drobo Dashboard cannot see the Drobo
  • Finder also cannot see it (as opposed to before when I could access via Finder, just not via Drobo Dashboard)

I’m wondering if the missing DDserviced is the problem…

Thoughts on where to go from here?


hi shawn,
there was a new version of dashboard that came out a few days ago (though it sounds like you did try that one, which is version 2.8.2)

in case the latest version you tried was v2.8.1, then please try v2.8.2, though if you already recently try v2.8.2, then you might need to specifically try the uninstall process to remove it completely (just in case any remnants are causing problems)

then would you be able to try a slightly older version, which can be found here?

(im not sure what firmware version you have, but if v2.8.2 and v2.8.1 have not been working for you, maybe trying a version prior to that could help)

interestingly enough, there was another user who initially had problems getting dashboard to find their drobo on macbook, though their imac was ok: http://www.drobospace.com/forums/showthread.php?tid=146180

also, if you have a tool called appcleaner, another user mentioned their process for using that, partly before and after the uninstall process here:

OK - 2 questions.

  1. Should I go back to WiFi setup to test the older DD or keep my 5N physically connected?
  2. Do you know where I can download DDserviced?

hi shawn,
for 1) please try keeping as direct connection (not wifi)
and for 2) it should be part of the dashboard install process (though some references to it might still be misnamed in some dcumentation as per here) http://www.drobospace.com/forums/showthread.php?tid=146180

OK - I installed v2.5.4 but no improvement…

thanks for trying that version shawn,
there is an ftp link on this page, which has some more versions of dashboard for you:

maybe you could try some more versions that you have not already tried, if you get a chance, in case a specific version works for you?

also, at the the bottom of this page: https://myproducts.drobo.com/article/AA-01863 it mentions what you have already done (which is to enable access to ddservice64d), but, on that option, could you try disconnecting from the internet, and then actually trying to “disable” your mac firewall, just as a test?

btw are the lights on your drobo all solid lights (ideally green) and no flashing lights on the drobo when trying to connect?