Drobo Dashboard 2.6.7 Released

Hello Drobo Users,

We are proud to announce the release of our latest Drobo Dashboard, 2.6.7 for both Windows and Mac.

Release Notes

This release does include many bug fixes, and we would strongly recommend updating to this latest release.

This release does have improvements to the share settings on the 5N, and the 5N will need its firmware updated to 3.2.2 to be compatible with 2.6.7 dashboard.

As always, if you hit any issues, please collect a set of logs and file a case with support.

Connected Data Support

I upgraded to 2.6.7 and now dashboard cannot see my 5N. Yes, I’ve made sure that my firewall settings are correct. Did I need to go to firmware 3.2.2 first or something?

My finder is working, but dashboard is not.

Any help?

  • jon

Same here, I checked my firewall setting and directly connected my Drobo to my machine. Finder works fine but the Dashboard is a lame duck. Any fixes?

I was a very vocal critic of 2.6.4.

Just wanted you to hear 2.6.7 resolved all my issues and is stable on my Gen2, Gen3 and 5D.

Thanks for listening to the user feedback and fixing the problems.

I just upgraded to Dashboard 2.6.7 on my Mac and can no longer access both my Drobo 5N and FS. My wife did not upgrade Dashboard on her Mac and she can still access both Drobos. I confirmed we have the latest firmware version on both Drobos (3.2.2 on the 5N and 1.2.6 on the FS). Is there an issue with Dashboard 2.6.7? If so, please let us know the fix.

Try 2.6.8.

  • Jon

Thanks Jon. Dashboard presented me with the option to upgrade to 2.6.7 (no mention of 2.6.8) so I did. Little did I know that version is targeted for Windows platforms, not Macs. After visiting Drobo’s website I confirmed your recommendation, uninstalled 2.6.7 and installed 2.6.8. Now Dashboard recognizes both of my Drobos.

I’m a bit surprised the routine that recommends the Dashboard upgrade is not able to sense the platform it’s running on and as a result recommends the wrong version number for a Mac. Maybe something Drobo could improve on in the future?

I’m in the same boat as some other people here. Got the upgrade popup in the dashboard and said yes. Once the upgrade was complete, the dashboard will no longer see my B1200i. I can still access the storage via the iSCSI network, but not the dashboard via the management interface. I’ve tried uninstalling the dashboard software and reverting to v.2.6.4, and even all the back to 2.1.0 (from the original installation disc). I’ve also tried installing the dashboard software to a few different PC’s but none of them are able to find the drobo. I have tried automatic discovery and manual discovery to it’s IP.
I am able to ping the drobo’s management port and it has been rebooted manually.
The event log (Windows 7 and Windows server 2008R2) shows that DDService.exe is crashing every 30 seconds. These crashes started when the upgrade was completed on the original system that had been running the dashboard software for several years.

Anyone have any ideas?

Example entries:
Application Error ID 1000
Faulting application name: DDService.exe, version:, time stamp: 0x54b46507
Faulting module name: MSVCR90.dll, version: 9.0.30729.6161, time stamp: 0x4dace5b9
Exception code: 0xc0000417
Fault offset: 0x00036db8
Faulting process id: 0x768
Faulting application start time: 0x01d0a2d534fdf5aa
Faulting application path: C:\Program Files (x86)\Drobo\Drobo Dashboard\DDService.exe
Faulting module path: C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll
Report Id: 87cfdadb-0ec8-11e5-a282-005056c00008

Windows Error Reporting, ID 1001
Fault bucket , type 0
Event Name: BEX
Response: Not available
Cab Id: 0

Problem signature:
P1: DDService.exe
P3: 54b46507
P4: MSVCR90.dll
P5: 9.0.30729.6161
P6: 4dace5b9
P7: 00036db8
P8: c0000417
P9: 00000000

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 7277e62e-0ec8-11e5-a282-005056c00008

I finally had a maintenance window and was able to reboot both the B1200i and the main server that we run the Dashboard software on. It was able to reconnect using dashboard 2.6.4. I have not tested performance since then, but plan on doing so soon.

Why the main " download page " does not show the dashboard 2.6.8 for download !?
Does 2.6.8 fix the dreaded " A required portion of Drobo Dashboard is no longer running. Please relaunch Drobo Dashboard to correct the isuue. If this … ".

I have tried the 2.6.4 ( the only available thing on Drobo’s site ) on MacOSX 10.6.8 and Yosemite with the same error.

  • MacOSX 10.6.8 , Drobo gen 2 ( Firewire ) NO GO !
  • MacOSX Yosemite , Drobo gen 2 ( Firewire ) NO GO !

hi i found a mac version here, though it was a manual link.
(it might just be that the main download page only shows 2.6.9 as the latest, but it could also be that 2.6.8 had a bug as was superceded by 2.6.9)

(manual link)

before you try any new dashboard software though, can you have a look at the mac firewall settings, as usually the dashboard service needs to have firewall permissions to work properly, and it might fix it for you.

I have firmware 3.3.0 and I’m being told that I have to go to 3.5.9 using dashboard 2.8.4 highly confusing as a novice but getting some headway here on my MacBook. since i had no drobo apps and now i have my drobo access and pix installed waiting to go to the next step to use them. i use auto update and nothing occurs, i tried finding a way to manually get to 3.5.9 but its just non existent from where i’m looking. what do i do

hi jyellowhorse, i think you still have a 5n back from this thread?

if so, there is a page here that has latest firmware available:
(along with release notes and manual updating instructions on the right hand side)