Drobo Dashboard 2.6.4 (yosemite connects via SMB now) ISSUE

I just installed 2.6.4 Dashboard.

The issue…

I have my shares mounted via the Drobo Dashboard, but now my share won’t mount when I click on it. It gives me a, “Drobo Dashboard could not mount this share” error window.

I can mount the share via AFP and SMB via Finder, but can’t via Dashboard :confused:

Try dismounting the share via Mac (eject Drobo 5N).

Uninstall, and reinstall Drobo Dashboard (may need you to enable exceptions on your FireWall settings again).

Try mounting the share again via Drobo Dashboard and see whether this helps resolve the issue?

I eventually got it to work, but now hit with OS X’s FINDER SMB issue… basically the Finder will eventually have an issue transferring anything off a NAS after a few hours (usually about 2 hours for me), and it will need to be relaunched for it to work properly. Still no fix in sight :confused:

AFP and transferring over SMB1 has the same effects on my system :confused:

I am running into the same problem after updating Drobo Dashboard—everything was working fine before the upgrade, but now although Drobo Dashboard and the Drobo 5N both seem fine (Status is good for all drives, hardware lights are good), none of my shares will mount as noted by the OP (except that I haven’t gotten them to mount at all). Is it viable to downgrade back to the previous functioning version or is this a Drobo software/driver/firmware problem under Yosemite?


What happens when you try and click mount in Drobo Dashboard?

First, “drobo; Please wait…”.

Then, “Error: Drobo Dashboard could not mount this share”

Before the upgrade and reboot, shares were mounted and were working just fine. After the upgrade, shares don’t work but the Status and other menus seem to be getting information from the box just fine.

Something similar was happening on my system … try this:

after you receive that error message, force quit (relaunch) the Finder and then click on it again. Did it work this time? That did the trick for me. After that, every subsequent restart of the computer mounted the share fine for me.

The issue is ultimately SMB, there will be lots of issues that are ultimately tied to the Finder (not the core OS). Reverting to AFP or SMB1 (CIFS) didn’t work for me either. The transfers will drop, and eventually i had to relaunch the Finder to get it running smoothly again (until an hour or two later when I would have to relaunch the Finder again).

So far, I’m connecting over NFS and it’s working fantastically! The first time I’ve felt this way since owning the 5N!

Thanks for the suggestion. I’ve tried this keeping Drobo Dashboard and restarting it between regular quits (Finder File menu) and force-quits (Activity Monitor button). Neither of those worked for me. Is there a way to configure NFS instead of SMB or AFP?—if so, I’m all for it (it’s worked well enough for decades—why change?).

I looked and seem to have Drobo Dashboard 2.5.4 on my system—should I try downgrading to that? It was working fine before I upgraded to the latest 2.6.4 version…


^ for me, NFS is what worked, and so far, seems to be working well, with a few minor quibbles. The additional metadata doesn’t stick over SMB or NFS, but the performance gains for me made me figure out how to get NFS working. It requires adding SSH, and NFS 1.2.8 to your Drobo (enabling droboapps).

Have you tried manually mounting your shares via the Finder’s “connect to server” function? Does it mount then?

I have not tried using the “connect to server” option but will give it a shot when I get a chance later this week (as well as trying to instal SSH and NFS on the drobo); my drobo room just became a guest bedroom so it might be a few days or more until I get the opportunity to experiment further!

I’m using rsync to mirror to the drobo anyway, so I’m not sure that I really care about the OS-X metadata on these drives…

I’ll post my results when I get a chance.

OK, for the moment the connect-to-server feature seems to be working. I haven’t found ssh (Dropbear doesn’t exist on my DroboApps list) or nfs (one link is no longer working) but did find Fuse which may have superseded nfs. I’ll see how the connect-to-server thing functions for the moment and go from there. But if nfs is faster, then I’m all for trying to install it onto my Drobo!

NFS: https://sites.google.com/a/droboports.com/www/app-repository/nfs-1-2-8/drobo5n

OpenSSH: http://www.droboports.com/app-repository/openssh/

Sudo: http://www.droboports.com/app-repository/sudo/

Download those three things (bare minimum to get started), those are the only 3 I have running on my Drobo, to keep things minimal.

Install sudo, then openssh, then nfs. NFS will require some tinkering around to get it working since you’ll most likely run into permission issues (write issues) between Yosemite/Drobo. I’ve managed (finally) to work around all the little quirks. I would compare your read/write speeds between these protocols: CIFS, AFP, SMB, NFS

Mine by FAR is best using NFS. It’s not even close. The other three I have major dropping issues with that requires me to keep relaunching the Finder :confused: