Drobo

Drobo Copy broken on W7 / Dashboard 2.0.3

There’s so much wrong with with the Drobo Copy on my Windows 7 x64 system, I’m not even sure where to begin. Basically, it’s totally broken and doesn’t do what it’s supposed to. I’m using version 2.0.3 of the Dashboard.

First off, for about half of my backup jobs it always fails with an “Unable to complete” message, spewing some spurious “Access Denied” messages to the backup log for some (always the same, though) directories, some of them on the source side, some on the destination. I’ve double and triple-checked and no - the resources in question are in no way locked or otherwise protected. I can manually open or copy them back and forth anytime I want, using the same user account the Drobo software runs under. I failed to figure out any pattern for what is copied successfully and what is “Access Denied”. And now the funny part: when you delete the destination backup directory and then try to trigger the job again, it will give you the same error but won’t even copy back what it managed to backup the first time! In case my description is a bit messy, here’s how it goes for me:

  • Create a Drobo Copy job to copy the “C:\Users\Me\Documents\Important stuff” folder to “E:\Backup\Important stuff” on Drobo. There are folders “One”, “Two”, Three" in it, each of them in turn contains several files/directories.

  • If you didn’t bother to check, if and how it actually worked, you think all is safe and sound as there’s no obvious persistent notification after the nightly failed backups.

  • When you run the job manually with a Dashboard button, you get a brief yellow box on the desktop saying the backup couldn’t complete. When looking into the backup job log, you can see there was an “Access denied” for “C:\Users\Me\Documents\Important stuff\One” and “E:\Backup\Important stuff\Three”. Yes, some of the errors are on the source side, some on the destination (Drobo itself). By opening the target directory, you confirm said dirs were not copied. The “E:\Backup\Important stuff\Two” is fine, though.

  • Delete the target “E:\Backup\Important stuff” directory just to re-run it and see what happens. Again, Drobo Copy fails with the yellow box but now fails to even notice the “E:\Backup\Important stuff\Two” is no longer there and doesn’t even try to recreate it!

There are no errors in my file system, chkdsk completes fine.

How on Earth did the data protection-oriented company manage to FUBAR such a simple task so badly is beyond me. Now, that’s embarrassing.

I’m having the same problem… This is BRUTAL. I can’t believe how badly DRI 'effed Drobocopy up! Seriously, I bought my FS last winter, and it’s somehow becoming less and less functional as time goes on? WTF?
The only workaround I’ve found is to create a new folder, move all of the files from the “access denied” folder into it, delete the old folder off of both my local machine and the Drobo, rename the new folder and re-run DroboCopy.

Ridiculous. Seriously.

I am having the same problem. It won’t detect the drobo unit and drobo copy fails right after it starts.

I opened up a ticket w/ DRI on this issue a couple of weeks ago; it had gotten to the point where the Dashboard wouldn’t recognize my FS, and wouldn’t mount the shares. They had me completely uninstall the 2.0.3, re-download it, re-install it. That fixed the issue with it not recognizing the Drobo. (I actually re-installed an older version of the Dash, but no luck; DRI told me that the current firmware won’t play with the old Dashboard, left me unable to login as administrator, mount shares, do ANYTHING, basically…)
The DroboCopy was still broken, so I followed up with them on that and was told to just start using a 3rd party backup tool like Sync Toy. Arg. A long, slow clap for DRI, ladies and gentlemen… They didn’t want to bother fixing the problem, and actually directed me to a competitor’s backup solution. Anyway, I complained about their response, and they sent me a license for their own DroboPC Backup software. Again, no solution, just a workaround.
I was going to rollback to an earlier firmware, so that I could get the older, working Dashboard back, but got this reply:

"You can roll back to a earlier firmware, I would HIGHLY recommend you have a backup of your data on a separate device before attempting to do so. Drobo copy is actually just a front end for the your Microsoft system scheduler that’s stock with every Windows install. "

Which means what, exactly…? Anyone know? Did the new Dashboard install somehow bork my Microsoft System Scheduler or something…?

Bleah. Why didn’t I just go with the Synology like I’d initially planned on doing…?

Same problem that I’m having with my Win 7 x64 system using Drobo Copy to my FS. Worked great with the old version of Dashboard & FW, but now I’m getting the same issues noted above. The copies just don’t work, so nothing is being back up.

Pretty unsatisfactory…

Andy