Drobo chewing through WD Reds.


I purchased my Drobo from Amazon back on February 6th. Everything was running perfectly. Then I installed Firmware v3.2.3 in June and since then I have been through 5 Western Digital Red drives. I have tried rolling back to v3.2.0 but the dashboard still detects drives in “Critical” state.

If I plug the drives into my Windows or Ubuntu machines they are detected just fine. This is what is making me lean towards the Drobo being defective.

Are there any recommendations on what I should do next? I really don’t want to have to keep RMAing these Red drives every 2-3 weeks…


Try RMAing the Drobo instead. While it’s still under warranty you’ll get their support team’s undivided attention.

However, when you say that the drives are “detected” by Windows or Ubuntu do you mean just that, or have you performed any tests on them in those environments? Have you checked their SMART status, for example? Have you run the SMART self-test (short or long)? Have you run any diagnostic tests suggested by Western Digital?

Yep, I ran the Diagnostics tool and it reported all drives as fully functional but the Drobo detects them as failed.

I’m going to do a complete system reset and remove the mSATA drive I have attached (Samsung 850 Evo 128Gb) and see if it is maybe related to the M.2 drive. I don’t do anything on the device but store media for Plex so it’s disk I/O is next to none.

Doing a pinhole reset seemed to get all the drives to report as “Good” again. I will be stress testing the drives over the next 72 hours with Plex and Photoshop to see if they fail again. Maybe it was just a firmware bug? I’m also running v3.2.3 again. I’ll report back with an update in a couple days.

Ok. Good luck. It seems like you’ve made some progress. There are a lot of reports about suspected bugs in v.3.2.3 of the firmware (though Drobo is admitting nothing) resulting in hard drives and mSATA cards being rejected. Then again, I don’t know which version is considered to be “safe” to use. I’ve only experienced two versions. My 5N came with 3.1.1, which seemed to be fine. After much nagging by the Dashboard I upgraded to the then current 3.2.2 and experienced my first crash soon afterwards, but after re-booting it it’s been running fine since May. I now ignore the nagging. Until I’m given a convincing reason I’m sticking with what seems to work. Meaningful release notes would help.

Sorry to hear this, this is not normal. There are no known issues with these drives. Do the drives fail in the same slots ? We do not recommend rolling back the firmware as not all versions of firmware are backwards compatible, doing this can cause data loss. One other note, if the drive has been marked bad by Drobo ( the drive bay blinking Red) then the drive has been expunged by Drobo. The Drobo will mark this drive and you will no longer be able to use it in Drobo again. May I ask, how did this drive fail ?

Thank You.

So if a faulty Drobo erroneously marks a drive as bad, how do you make it usable again? Would repartitioning it with Windows or OS X overwrite the flag?

To answer the DroboMod: The drives just started flashing red randomly. There were no real noticeable reasons as to why. No Time Machine backups were occurring, no one was watching Plex media, or anything like that. And keep in mind, my Drobo is ONLY for storage. I run Plex and every other HTPC software on a dedicated i7 HTPC machine laying in my storage closet. Drobo is simply a network share attached to all my machines.

It sounds like Drobo stores the device ID, or something, of the failed drive in a local store. Doing the pinhole reset completely reset the Drobo to factory settings (with the installed firmware of v3.2.3 since I installed it before the reset). This process must clear that cached data, wherever it is, as those drives did not move slots and are now reporting “Good”.

To me this sounds like Drobo may be being overzealous on faulty hardware; especially if the Western Digital Diagnostics Tools say their own drives are completely fine…

Good thing is I have about 50 hard drives laying around the house from over the years and I can back up my data other ways to reset the Drobo if I ever run into this again. It’s time consuming, but at least there’s a solution.

hi, 5 in a row does seem a bit odd, though i was wondering if you happen to remember the serial numbers (just for your own info) to see if you can spot if they all came from the same batch?

maybe amazon had a bad batch, that were all affected in some way. (it might not be that, but i bought a box of 7 drives in the past to get a good deal, and they all arrived in the same box to me. and i had my first drive of that batch fail over the weekend. :frowning:

(im hoping that its not a sign of things to come, as they have been all used for 4-5years - but because they all were delivered to me in one go, and have been used for the same amount of time approximately, i havent ruled it out) :slight_smile:

I have a Drobo gen2 and have been running it for many years now. I have mainly used WD drives of different types and some of them have been marked as failed by the Drobo. In all 3 instances, I have been able to connect them directly to a computer and 2 of them even passed the standard test of the WD test program. Issues were only detected when I used the WD program with the long test. It took many hours to complete.

My understanding is that Drobo is very good at detecting problems very early, well before you lose any data. It might be a bug in the Drobo firmware, but you should do the long test using WD test program. I think it was this program I used:

If this is happening in different slots it is unlikely a Drobo issue. To answer your other question it is possible for you to use the drive Drobo marked as bad in a computer or device other than a Drobo after you have reformatted it. I would just keep an eye on it.

I believe I’m having the same problem. I just upgraded a couple of my 5N’s drives to WD Reds (3TB). Within days, one of the drives has failed.

Coincidentally, the 5N lost the ability to see my mSATA drive around the same time.

The device is just under 2 years old, so it’s out of the initial warranty period.

At the moment, I’m running the WD extended diagnostics on the failed drive. Will see if it passes or fails. (It passed the short diagnostic test without issues.)

I wonder if the 5N firmware just doesn’t like these drives?

hi it took me about 17 hours to run wd tests on a 1.5tb drive, would be interesting to know how long it took you on the 3tb if possible please?

It took my PC around 6-7 hours to complete the long test on the 3TB drive.

It was a PASS. The Drobo seems to be falsely labeling drives as bad. I’ve run the WD utility and other hard drive utilities against the drive. No errors at all.

Got to be a Drobo problem.

thanks for the time info

its possible though there might have something with the drive that was within the tollerance of the wd test, but which drobo picked up on. in one of my drobos, in a rather lengthy thread here:
my 4-5 years old drive failed, but even though the wd util showed a pass, i put a new one in to play safe.

ill still use the failed drive as an extra backup of things (eg as a stand alone drive) but even if you do have a way of making it work in yours again, i probably wouldnt recommend it to play safe.