Drobo Apps share i refuses access

I wanted to update my plex app with the latest version as drobo have not updated there one. The forum said take the file and place it in the drobo apps share. I did this fine with my first drobo 5N but the second refuses me access and doest accept the admin username and password. I have tried turning off drobo apps and also removing the running apps but still the same. How can I reset this share and make it use the current admin username and password.

Usually a simple reboot fixes most of these problems.

As I mentioned before I have tried a number of methods before raising this issue. I removed apps from the drobo. Turned off apps. Even changed the admin password. naturally this required a reboot a number of times. However I fail every time to log in to the Drobopps share as it doesn’t accept my username and password. Is there a way of resetting the unit without loosing all the data on it?
I do hope someone can help me on this.

Does your password contain special characters such as $&"#’;!?

Yes the password had a - in it the rest of the password is numbers and letters

Can you please upgrade to the latest firmware and Drobo Dashboard? In the release notes of one of the more recent versions there was a mention of better handling of passwords with special characters.

Once you are on the latest firmware and dashboard, please try to set the admin password again to make sure that it is stored correctly.