Drobo

Drobo and VSS

I’ve got a Drobo v2 running 1.35 firmware and DD 1.6.6 on Windows 7. I haven’t had any issues until I tried using a backup solution that uses Volume Shadow Service.

The moment it comes on, DDservice.exe goes to 100% cpu time. I can’t kill it, but I can lower the priority so that I can keep working. At first, I thought it was the backup software (Mozy), but I tried a few others and it does that same thing the moment Volume Shadow Service is invoked. Any ideas?

Thanks!

If it’s 32-bit Windows 7, you might try Prio, which lets you permanently save the priority of a service. I’m not sure it’ll run on Win7, so best to create a Restore Point before you try that.

I’ve experienced the very same behaviour while using Mozy’s open files backup feature (which depends on VSS) and documented that on this forum.

I’m pretty sure this won’t solve the problem, unfortunately. When VSS snaphot is attempted, Drobo is essentially dead and all processes (not only services - userspace processes as well) trying to access it (not only Dashboard) are stalling in some seemingly endless loop, causing 100% CPU usage.

I wonder if it has to do with Thin Provisioning and the way VSS allocates space?

How big is your Drobo formatted?
This post seems to imply that VSS may have a 5TB limit.

Remind me in a week or so and I’ll try it on my 16TB Drobo under Win7.

Thanks for the info. That very well could be it. I’ve got my formatted to 16TB on Win7 x64. It’s only while VSS is active so I suppose it’s not that bad, but it is a bit frustrating.

I need to do some secure replication anyway and my copy application (ViceVersa Pro) supports shadow copy so I’ll give it a try in a few days.

I started a ViceVersa Pro (v2.5) copy with VSS enabled for Source (I’m copying data from my local Drobo to my WHS machine’s Drobo) on Vista x64. So far, DDService seems to behave properly. Will check back in a number of hours (ViceVersa will also email me if something goes belly-up).

I don’t think there are >5TB files in my current copy operation though… will have that later in the week when I tackle some 30+ GB files.

Oops, seems I was mistaken. It’s copying a 16 GB file now. :slight_smile: So far, DDService.exe is still using 0%.

So I tried a copy on my Win 7 x64 machine, and while DDService did not spike CPU usage, the shadow copy creation process went 8+ hours and didn’t complete, so aborted it.

Seeing as the same operation completed on Vista, either I screwed up the test (not out of the question), or there were some VSS changes in Win 7.

hi if it helps at all, i use Mozy to back up some things from my drobo and no issues like that are encountered, (at least not yet). ive had 1 ddservice.exe issue so far, but a full reset fixedit.

i havent used mozy for 2 days (suspended it while doing other operations etc) but so far no issues there.
(my drobo’s are ntfs and max vol 2tb each)