Drobo 5N2 not discovered by Mac on Big Sur

I updated two MacOS computers to Big Sur and my Drobo 5N2 is now not discovered by Drobo Dashboard (I’ve tried uninstalling, reinstalling, rebooting, in all combinations - to no avail). The Drobo 5N2 is still discoverable by another Mac still on High Sierra and it appears to be working fine. It is also using the latest firmware and I’ve updated to the latest Dashboard.

I’ve tried different privacy settings and even turning off the firewall - nothing works. I’ve even searched for it by IP address and it is not discovered. BTW, my Drobo 5D connected through thunderbolt just fine.

I’ve searched for advice everywhere and I can’t find anything about Drobo 5N2 and Big Sur - except that Drobo says it works.

Same issue with a Drobo 5N. I’ve checked Firewall, and it seems like Drobo hasn’t put the correct application in there so I can enable firewall bypass for Drobo traffic. Even when I turn the firewall off, it still doesn’t see the Drobo 5N though, which is kinda puzzling.

Sorry to hear it. Good luck getting anything out of Drobo - as you can see, no one has responded since I posted. I suspect the company is dying. I went ahead and just bought a completely different solution from a different company - and it is working fine. I guess I got at least some use of the Drobo for a few years, so it wasn’t all bad - but there is no way I will spend another dime with them. Support is just too absent.