Drobo

Drobo 5N2 802.3ad Link Aggregation

Hi all,

I’m having a bit of trouble getting 802.3ad link aggregation/bonding set up with a Drobo 5N2. Is there any documentation available? Has anyone managed to get it working?

-JP

I had a tough time finding information about this topic, too. The first thing you need to know is that you need a managed switch or router that supports port bonding (802.3ad), at least in firmware 4.2.2 which introduced true 802.3ad support. My network equipment does not support this functionality, so I gave up on it until I can upgrade my gear.

The doc is a little light on this topic, but there is some information here:

http://manuals.drobo.com/#t=5N2_Setting_Your_Drobo_5N2_to_Independent_Network_Mode_or_Network_Interface_Bonding_Mode.htm

http://manuals.drobo.com/index.htm#t=5N2_Configuring_Network_Settings_(and_IP_Addresses)_for_Your_Drobo_5N2.htm

https://supportportal.drobo.com/retrieve/s3/knowledge/AA/AA-01125.html

However, the best information I could find about this topic is not from Drobo at all. You can find a pretty detailed article here:

I hope that helps!

1 Like

Many thanks for the reply, Dom. The switch I’m using definitely supports 802.3ad LAG, it’s just not negotiating the link for some reason. I have SSHed into both the Drobo and the switch and my current thinking is that the setting isn’t getting set properly on the actual Drobo, despite what’s selected in Drobo Dashboard.

I’m working through the issue with Drobo support so hopefully I’ll be able to get it working eventually.

-jp

It looks like we had the same idea. I also opened a ticket to see if I can still use the method (that doesn’t require 802.3ad) detailed in the non-drobo link I shared earlier.
One last thing came to mind: is your 5N2 already on firmware 4.2.2? That is when 802.3ad support was officially added.
I’d be curious to know the results of your interaction with support, if you can share them once the ticket is done. Thanks!

1 Like

The other bonding method is supposed to work with any switch, but I didn’t see any improvement in overall throughput (with several clients using) above what I would expect with a 1Gb uplink.

I’ll keep you updated.

Since I don’t have any 802.3ad network hardware, I went with the “ALB” bonding method. The response I got back from Drobo is that this method provides no performance improvement. It is meant to act as a failover all the while using the same IP address.
Using port aggregation (802.3ad), you should see theoretical speeds of up to 2x the regular speed. However, you may need to enable Jumbo Frames to do this. This might not be feasible unless all the devices on your network can be set to an MTU of 9000. The recommendation is (possibly) to isolate the Drobo on a separate LAN or VLAN. Without jumbo frames, your speed should still increase, but not twofold. Again, this is all based on the podfeet article I linked earlier, so take it with a grain of salt.

Good luck!