Drobo

Drobo 5N won't mount as registered user

I can’t log into my Drobo 5N from using macOS HighSierra and Windows 10.

  • Using SMB I can only login as a Guest but not as a registered user.
  • Using AFP I can’t log in at all.
  • Using Drobo Dashboard I’m getting this error:
    Drobo Dashboard could not mount this share

I’ve tried both, to disable and enable SMB v1, none worked.

Does anyone know a solution?

Thank you.

I’ve contacted Drobo support. They offered me a to buy DroboHelp, which is paid support at 49EUR. I think that’s ridiculous as I’ve never touched the Drobo and I’m pretty sure it’s a Firmware issue. I think long term I’m going to move away from Drobo. But I will give this another try for now.

I’ve tried to login via SSH and run smbpasswd to manually set the password of the samba user. It returned an error “Bad SMB2 signature for message”. Not sure what this means but obviously there is a problem.

I’ve now downgraded to Firmware 4.1.3 as suggested in this post: Drobo FW 4.1.4 broke SMB (for me). What is your experience with 4.1.4?
Unfortunately without luck.

I’ve downloaded Diagnostics from my Drobo using Drobo Dashboard.

The “smb.log” file shows a lot of errors like this one:

../source3/auth/pampass.c:89(smb_pam_error_handler)
  smb_pam_error_handler: PAM: session setup failed : Error in service module

It seems like every time I enable read/write access for everyone it creates this entry instead:

STATUS=daemon 'smbd' finished starting up and ready to serve connections