Drobo 5N - Single Red Light and Does Not Detect HDDs

I’ve seen odd behaviour like that on my 5C, it turned out to be a faulty drive that wasn’t being kicked out as faulty… the trick is identifying the culprit without involving support & having them interpret logs… best of luck… I can’t offer a lot of useful advice on that identification.

It’s unfortunate that the log reader is not public. The information support was able to give me (while I was still in support last year) about a drive that acted strange only once was invaluable. The drive was failing, but somehow not being reported as failed by my Drobo 5N2. The logs I sent support immediately showed that the drive needed to be replaced.

They were able to read in their encrypted logs the following:

“J2::doSpill: power cycling slot 1 because too many disk flush failures​”

And suggested that I replace the drive. I NEVER would have seen this without their interpretation of Drobo’s logs. :frowning:

So, yes, it’s pretty much a guessing game to figure out which drive has failed, unfortunately.

Regards,

Dom

It’s one of those situations where a body like the EU that has some clout could make themselves useful…
“If a device creates logfiles those logfiles must be accessible to the user for checking”.
Might be an actually useful regulation.

Would be rather more use than making everyone click rubbish about cookies on every site on the entire web…

On second thoughts… those idiots would probably require you to read the logs in there entirety, aloud, every start-up. If they made a rule it’d have to end up as annoying as the cookie nonsense.

I know this is from 2018 but this just happened to my 5D. I was freaking out because of these threads. But all you need to do is use a vacuum that can BLOW all the dust out of the thing, and it’s back in action.

Don’t think that’s so easy. Mine is totally clean inside. If it is a few days off it works again for a while. Then error comes back. I assume a dead Capacitor somewhere. Aka planned obsolescence.

Hi there
I’ve had the same problem overnight.

I have three Drobo FS - and I was wondering if I could move the 5x drives I have the 5N to an FS to pull all the data off of those? Does anyone know?

Everything I have read suggests you can only go from older to newer, not reverse.

Thank you

Yes, you can. BUT you have to do that with shut down and switched off device and have to do it exactly in same order of disc’s
If you do it with running device your discs getting formatted. So:

  • switch off both devices and remove from mains (wall plug)
  • take out all discs from target device and store it on correct order
  • take out the discs one by one from source device and put in the same slot on target device
  • if you have all discs in target device (and not earlier) switch on the target device

I recovered my data this way from old broken Drobo 5N to new bought Drobo 5N1

Thanks for your response. But does this work from Drobo 5N to older generation Drobo FS ?

I have three operation Drobo FS. The Drobo 5N is the one that is not functional hence wanting to move those drives to the FS.

Give it a try. As long the Drobo is OFF while changing discs your discs get not formatted. Only if you plug a disc in a running Drobo formatting starts immediately and all data get loss on this disc. If you move the whole stack over, while switched off, you take the OS with it.

By the way, you haven’t other chances to recover your data. You could contact the Drobo support, but you‘ll have to pay horrible fee, if your Drobo is out of warranty and finally they‘ll tell you the same

You can Google for Drobo 5N Migration to find a compatibility List (from which Drobo you can transfer the stack to what other Drobo)

You cannot move a disc pack from a 5N “backwards” to a FS.

Here is the migration path:

So you can only migrate from an FS to a 5N.

The FS only supported 16TB volumes. Unless your 5N was itself migrated from an FS directly or its disc pack was created on a very old firmware, the volume will be 64TB and unrecognizable by the FS.

Your only migration paths for your 5N disc pack are toward another 5N or a 5N2. Sorry for the bad news!

Regards,

Dom

Thanks all for your help. Pity, as I have 3 Drobo FS that have been faultless for nearly 10 years now. If I had a 4th FS I’d be set. Can’t go from 5N to FS.
Drobo Support did respond to my queries and have offered for me to send my unit to them for repair for ~$350 USD. Anyway, I will recover the data and get a Synology.

I finally found success in recovering Drobo 5N files via UFS Explorer (cue happy dance).

To recap, after 9 years, my Drobo 5N one random morning failed to find any installed disks, and displayed the single red light next to the top drive. I updated firmware, cleaned out the enclosure, even bought and replaced the industrial battery inside, all with no change. The Drobo is dead.

I spoke with Drobo support, who, after a week or two, finally confirmed that their parent company is bankrupt and no service would be available for my product.

I spoke with a data rescue company who said they could restore my disk pack for a minimum of $2600.

UFS Explorer software promises it can read Drobo disk packs, so I gambled on a new $150 basic 5-drive enclosure that would let me simply mount all the disk-pack drives on my PC at the same time via a USB connection.

UFS Explorer offers a trial shareware mode, so, once the disks were online, I was able to run the UFS software before buying the license. The software found and scanned my disk pack using their specific Drobo assistant and discovered two intact datasets, each using 3 of the 5 disks. I chose one, saw that the expected files were all visible, and when I tried to restore them, UFS Explorer asked me to pay the $150 license fee, which I did.

Then I was able to copy files over to my new NAS. I have had no trouble with corrupt files so far. Everything I’ve tried to open after restoration has worked great.

The enclosure I bought was a $150 “ORICO 5 Bay Hard Drive Enclosure USB 3.0 to SATA 3.5 inch Enclosure Magnetic Tool-Free External HDD SSD Enclosure Storage Case Built-in Fan for Data Backup, NAS Expansion Up to 80TB(5x16) - DS500U3”
https://amazon.com/gp/product/B0734G79FW/ It’s perfectly functional, but not not particularly robust. The drives drop in from top, and only gravity holds them on their connections. The back ends of the drive have a lot of room to wobble around at the top. But I loaded the drives up and tried not to disturb the box while I was in recovery mode.

So, in the end, failing to have a full current backup of my NAS somewhere cost me $300 and many hours of effort.

I’m thinking I’ll keep this enclosure and use the former Drobo disk-pack disks as backup copies of my new NAS.

1 Like

I have done a lot of troubleshooting on my Drobo 5N with this issue during this week.
3.3V, 5V and 12V is present on the SATA expansion board (the “Bumblebee & Shockwave BP V4.0” board)

But no power is being delivered to the SATA power slots. The three 3.3V pins read 0V, and the three 5V and 12V pins curiously read a few volts when I try to get a reading but they quickly discharge to 0 through the multimeter.

I replaced the thermal paste on the Marvell CPU and verified that the backup battery is working. At least that it reads ~4.2V and after being disconnected for a while the Drobo will charge it with a very low current (draws around ~0.1 amps while powered off and charging the battery and 0.06 when it considers battery fully charged).

I have connected to the Linux and vxworks serial ports but can’t really find anything interesting on the Linux port. Today I got the output from the vxworks serial port as well which I have uploaded to pastebin.com below. This output seems a lot more interesting but I really have no experience with vxworks so I’m not sure how to interpret it.

Perhaps someone else is interested and can make more sense of it, but I fear I won’t be able to save this Drobo. It would be interesting to learn what breaks down in this seemingly common failure scenario though for old Drobos. It seems like most of the components still work fine…