Drobo

Drobo 5N - Single Red Light and Does Not Detect HDDs

Hi Arnaud,

Thanks for your e-mail re: the Drobo red light issue.

I never got anywhere with their customer support.

My machine will occasionally start, and run for a few days but then it will crash again and refuse to start.

Totally unreliable and therefore totally useless for its purpose.

Have you any experience with Synology as a brand?

(Feedback on their customer support isn’t great either!)

Best regards

Hi guys, I experienced the exact same thing! One night all the lights turn green and the next morning a solid red light and no hard drive found. I sent a message now to Drobo support, and received the standard response that my equipment is out of warranty!

The last time I needed support in july, I paid for it US$ 49! And they didn’t help much!

From the messages seems to be something recurring in the Drobos 5N models! Can’t we get a complaint together?

Did all of you who had this problem, do the system update in Dashboard recently? Apache, etc?
Seems an incompatibility between the updates and the operational system.

I bought a brand new 5N2 and migrated the diskpack over

Time to play a bit with the old 5N. I unscrewed all and had a look on all components. There is no visible damage, no blown capacitors or else. So I only cleaned all and mounted it again.
Now I took 2 old Empty HDD‘s from shelf and put it into booted 5N. Strange thing - it detects the HDD‘s and performed formatting round about an hour and Show 2x green but Dashboard has shown Condition: critical although LED show 2xgreen. I found a support document which mentions in this case performing a factory reset. Because the HDDs are empty anyway I did this Reset over dashboard. After a while 5N came up again. Now with 2x green and condition: good. I have no clue how long that will stay but I‘ll let it run unused to see what happen. I‘ll keep you informed

So maybe give it a try:

  • shutdown 5N
  • remove your disk package ( note the order!!!)
  • boot the 5N with empty slots
  • put 2 empty harddisks in
  • let Drobo formatting it
  • perform a factory reset
  • let Drobo come up hopefully with 2x green
  • shutdown Drobo
  • remove the 2 harddisks an put your disk package back into Drobo
  • Boot the Drobo and see what happen

NEVER PUT DISKS FROM YOUR PACKAGE INTO A RUNNING DROBO - all Data will be deleted. Your disk package have to removed/inserted only if Drobo is switched off

3 Likes

Do you think it is worth trying this with a Drobo 5D.
My 5 year old 5D for the first time flashed red and said it was moving date from one of my five 1TB drives that had failed. Finlay it instructed to replace the drive. I did so with a New 3 tb . It didn’t read it, just kept flashing replace drive.
I replace it with another new 3 tb, the same result.
I like your approach is it wort trying on the 5D?

DroBo Frustrated

I have had the same problem with my Drobo 5D with the solid red light of Drive 0. I tried everything that is possible to try to fix it with the same result. My world of Adult Entertainment was in ashes. I read a post on another forum from a guy with the same problem that was resolved by pulling the Drobo apart and giving it a bit of a clean.

So last night I “bit the bullet” and decided to pull it apart and clean everything I could find with electrical contact cleaner. My Drobo has been out of warranty for a couple of years so I had nothing to lose if it all “went south” snd everything to gain It was surprisingly easy to dis-assemble and re-assemble. Well the good news is it has started working again ! I turned it on and up it came like nothing had happened. When I cleaned it it sprayed contact cleaner into the drive connectors and gave them a bit of a rub with a very soft toothbrush and I cleaned a lot of dirt off the fan but that was pretty much it, I have no idea what the problem was but can surmise that there was a short in there somewhere,

A couple of things to be careful of when dis-assembling the Drobo

  1. The power switch is connected by three fairly short wires so they are a bit tricky to reach so be careful not to over stretch the wires or they may break. Also take note of what colour wire is connected to what pin on the power switch because there is nothing on the wires or the connectors to say what colour wire goes onto what pin.

  2. The cable connecting the fan to the chassis is fairly short as well so care should also be taken there.

So if you have lost all hope then this is probably worth a try.

1 Like

Same problem. Walked into the office to find our 5N with the single red light on. The dashboard app just says “Add a drive”, while there were four WD Red Pro disks installed with at least 6TB of free space.

After rebooting, all four drives started blinking green and orange, and the dashboard app said “Data protection in progress”. The next day, all bays were orange, and the power indicator was completely off. The Drobo and the disks inside were making noise, but didn’t show up in the dashboard and I couldn’t ping it from my Mac’s terminal. After manually rebooting the machine again, I could acces my Drobo again. Three disks were green, but one showed a red light and indicated it had failed

I didn’t have a spare one ready, so quickly ordered a new 14TB WD Red Pro.
But when I replaced it, the Drobo didn’t recognize the new disk. It just kept showing as empty. I tried another empty slot, but also no luck.

Then I tried to reboot it again, but now it either shows up completely empty in my dashboard like before, or it doesn’t show up at all. Again without a light on the power indicator, but orange lights next to all bay doors. I really can’t tell if this is a hardware failure or firmware.

Has anybody had any succes in fixing this issue?

Besides all this, I find it annoying that Drobo’s customer support and warranty are so limited. WD gives 5 years of warranty on their disks, but Drobo after two years, Drobo lets its customers pay to ask a few questions.

Iskandar I have been grappling with a similar problem for the last two months albeit on a 5D but I dont think direct attached as opposed to network attached is where the problem is. i think its definitely a hardware problem and not firmware, you can read what I have done in the post above yours which initially fixed the problem, but it came back.

I have pulled the box apart four times now and cleaned everything I can get to with contact cleaner, but I think there is a short on one of the circuit boards or the boards are being affected by heat because i have managed to bring the drobo back to life three times now only to have it then hang after about fifteen minutes of it working perfectly again.

If only Drobo support was even halfway useful it would be good to talk to one of there engineers about this because i have read many have failed the same way. These boxes aren’t cheap so i cant afford to replace mine that’s why I have been trying to fix it.

You might want to try doing a hard reset of the Drobo.

  1. Shutdown the Drobo and make sure it is powered off.

  2. Remove all of the hard drives, you must do this or you will lose all your data. Label the drives so that you know what order they are stacked in because they will need to go back in in the same order after the reset. VERY IMPORTANT.

  3. There is a small hole next to the power on switch at the back, you will need a small screwdriver or a pen that fits into that hole. You need to put a small amount of pressure on the tool you use and you will feel a slight click as the reset button is depressed.

  4. Now you need to keep the pressure on the reset button and then power on the Drobo , you will need to keep the reset button pressed until the power light at the front is green and the red light on Bay one is hard on then you can let it go. This can take up tp five minutes to complete.

  5. Power off the Drobo again and re insert all your hard drives in the same order in which they were removed…

  6. Power on the Drobo,

If the hard reset doesn’t fix the problem I think at the end of the day you will end up having to replace your yoy Drobo as well, but the good news is your data is still in tact. Just remove the drives from the bays in the faulty drobo and label them in the order they come out in because if you get a new one they have to be reloaded in exactly the same order. Good luck and please post back here again if you find a resolution.

2 Likes

Thanks Sewren.

After rebooting a lot of times, all of the sudden the Drobo came back on again. Still asking for a new disk, but not detecting it when provided. But at least I can acces my data again.

I’ll put the new 14TB drive I bought in a USB-C enclosure and copy all data from the Drobo to it. After that, I’ll try your reset method.

UPDATE

I managed to copy al data to the new 14TB external disk using rsync. After that, I completely wiped the Drobo and did a fresh installation. It wouldn’t recognize any disks I placed in the bottom two bays, but it did work with with the top three bays populated. After copied all data back to the Drobo, it worked for about two weeks straight, before doing it’s single red light thing again. I’ve endlessly tried to reboot it, but no luck.

Long story short: I spend a morning learning about Synology, and ordered the DS920+ from Amazon.
https://www.synology.com/en-us/products/DS920+

What a breath of fresh air. I once decided to buy a Drobo because I found Synology a bit daunting with so many options. But I had the system up and running in minutes, and there are so many more possibilities. Besides that, it turned out to be way cheaper* than a new 5N2.

I’ve been a happy Drobo user for about three years, but I’m glad to have found an alternative. After trouble shooting for a couple of weeks with no help from Drobo, I hope this helps someone.

*At this time in Europe, a 5N2 costs €602 excluding VAT, while the DS920+ costs €485 and comes with three years of warranty, which can be extended to five years for an additional €87, while still being cheaper than the Drobo.

6 weeks ago my 5N started doing the same thing. The unit has been in service for 4 years and no problems.

I have DroboCare. So far support has not been terribly helpful or responsive; usually one response per week. Today the help ticket was closed; though replying to the message reopened the ticket.

I’m ready to write the Drobo off as a loss and go Synology or Qnap. Went Drobo because my brother really liked his. Plus there was a decent price. Should’ve stuck to the original plan.

Found my 5N with all yellow lights this morning. No amount of fiddling, swapping, rebooting or resetting had any effect and eventually just got the single red ‘add a drive’ situation. This is the scond time a Drobo has completely failed so I got into the habit of backing up the Drobo every week!. So even if I could buy a new 5N2 (the european Drobo store is ‘out of stock’) I’m not touching Drobo again. Ever.

Did you try taking all the drives out andd then doing a hard reset ?

Removed the disks, replaced the disks in the same and different order, tried 1 or any number of disks that had been in it or not, i.e. different ones I knew worked, hard resets, soft resets and anything else I could think of. Drobo dashboard only recognised there was a Drobo there 50% of the time, the machine usually refused to acknowledge there were any disks present and if it did it was saying that all disks needed to be replaced and if it wasn’t then it was saying a disk should be inserted.

If I was you (and I was and I did) I would disassemble the Drobo and fire some electrical contact cleaner across the circuit boards. I actually got my 5D working again albeit for a short time by doing that. It is actually fairly simple to pull the drobos apart.

Start by unscrewing the four screams on the bottom of the Drobo. The external metal housing then slides right off. Next is the plastic case that holds the drive, is is secured by four metal catches that need to be pushed in to free the case then you can pull that out.

Next there are four screws on each side of the exposed metal case that need to be removed. So at that point the case including the fan can be taken out. That bit is a bit tricky because it’s held together by the two cases sliding iinto one anothet also you have to detach the fan cable from the housing as well as the cable that provide power to the mother board. The cables must be detached before you can get to the circuit boards. Once detached the case needs to be lifted at an angle and slid out, that was there hardest thing to figure out.

Then clean the whole thing at with electrical contact cleaner also clean the fan then you can just reverse the instructions and put it all back together again and hope for the best.

the way I see it you have nothing to lose and everything to gain.

You are lucky you have a backup I did not. All of my data is intact on the dri es but I can’t afford a new Drobo. While doing some research there is some software that will allow you to access the data from Drobo disk’s as long as you can attach them individually to a machine running windows. The software costs about $200 however. And of course you need another set of disk’s to be able to recover the data too.

I am holding out for somebody to sell there old 5D so I can at least get the data off

Good luck mate

1 Like

Thanks for the tip. I’ll try it, but the problem is I just don’t TRUST the Drobo anymore. The last one I had continually went into recovery mode every few days meaning it was unavailable for 72 hours at a time before finally deciding one of the drive slots didn’t work. That’s not to say the grass will be any greener with another make but such failures without warning and stories about bad support don’t give me much confidence.

I agree. From many reports I have read the Drobo support is appalling. I certainly won’t be buying another anytime soon. The moral of the story is that it’s all well and good to be able to easily replace hard drives but a chassis failure can be catastrophic. To be 100% safe the chassis and the drives should be mirrored which is an expensive proposition for most home users.

1 Like

I got rid of Drobo and never went back. What good is backup if it’s not reliable?

1 Like

I know this is an old thread, but since there were updates as recent as 2 weeks ago, I thought I’d share too. Exact same issue happened to me. Was working just fine last night and woke up this morning to the single red light and won’t recognize any drives no matter what I try. Luckily have had all the data cloned recently so I have a decent backup to restore onto a new unit.

I went round and round with Drobo support a couple years ago. Took about two months to get resolution for a different issue. I don’t feel like putting that time or effort into this so it seems as though Drobo lost another customer today. Terrible support and unreliable hardware. Onward and upward!

Same here, went to my (home-)office today and 5N greeted me with a “all yellow dead discs”-freeze…

I tryed UFS Explorer RAID Recovery (can read Drobo Beyond RAID) but it is telling me that the Ext2/3/4 Partition (where Drobo stores its data inside the RAID) is corrupted :cold_sweat:

Currently it does a full scan for lost data… hopefully something meaningful comes from that… otherwise 16TB of essential work data is gone to dev/null …

If i can’t get this data back i wonder: Is it possible to sue Drobo for effektivly killing my bussiness?

Going to go ahead and add another instance of all bays suddenly showing as empty on my 5D as told by dashboard and the single red light on bay 0. Ive been having limited dialog with Drobo as to be expected. Their customer support used to be very helpful but now basically nonexistent. Luckily I have most everything backed up onto separate drives. Planning to get a Synology 6 Bay DS1621+ to replace this failed 5D. Thank you Drobo for wasting countless hours of my time.