Drobo 5N reboots when reading from share

My Drobo 5N has been working fine for years, but recently has started rebooting whenever I try to read from one specific share. I have multiple shares and they work as expected, but one share causes the Drobo to reboot when I attempt to read from it. I’m assuming there’s some problem with the file system, but I’d rather not have to reset the entire Drobo (I don’t have enough non-Drobo storage to back it all up, plus I can’t read the bad share).

Some further information on this: It turns out it’s not just rebooting when reading from the share, but actually a specific folder within that share. I’ve been trying to back up as much data as I can and have found that I’ve been able to copy other folders in that share without any issue. I’ll have to do some more testing to determine if it’s rebooting when reading specific files or if any file in that directory causes it to reboot.

I was ultimately able to back up everything from the bad share except for one folder containing approximately 300 GB of data. Every attempt to copy any of those files results in the Drobo spontaneously rebooting.

Assuming one of the disks may be bad (despite no errors showing in the Drobo Dashboard; which really needs some kind of diagnostic/repair functionality), I’ve decided to remove one drive at a time from the Drobo and try to copy the files. If the Drobo reboots again, I’ll replace the drive, wait for the Drobo rebuild process to complete (at least 24-48 hours each time so far), then try the next drive.

If I’m still unable to read the files after I’ve removed each drive (one at a time obviously), I’m just going to have to assume I’ll never get the data back and reformat the Drobo. Then re-evaluate my choice of NAS.

To be fair the 5n has worked fine for the past 7-8 years until now, so I really shouldn’t complain.

So I ultimately determined that the Drobo itself is corrupt, or the directory structure for the one directory I can’t copy is somehow mangled, not a physical disk issue. I would remove one drive from the Drobo and try to copy the files only to have it reboot itself. I reinserted the drive, waited a day or to for it to rebuild, then tried again by removing the next drive in sequence. Eventually I had tried removing each drive, including the cache card under the Drobo, but it still rebooted every time I tried to copy.

Too bad there’s no obvious way to do any kind of preventative maintenance or directory repair. The Drobo’s simplicity and ease of use is nice right up until something goes wrong, and then it’s a serious handicap.