Drobo

Drobo 5N Powers on, Can't add to Dashboard

Hello,
We just installed a Drobo 5N to replace our previous one that failed. This is a used unit we got off eBay since it’s impossible to find new ones. When powering it on, it gets a valid IP address and responds to pings, but I can’t add it to the Drobo Dashboard. When manually adding it, under status, it just sits there with a spinning circle and doesn’t detect the name. I’ve tried on our local network, and also directly connected using the 169.x.x.x IP address that the Drobo picks up. I’ve also tried different network cables and two different laptops, both with a fresh install of Drobo Dashboard 3.5.0. I also disabled the firewall completely to eliminate firewall issues.

All of the lights on the front are solid amber, and the power switch flashes green.

I’ve attempted to factory reset the unit by powering it off, unplugging it, depressing the reset toggle, plugging it in, then pressing and holding the power button (I’ve also tried without holding the power button) and waiting up to 2 minutes before releasing the reset toggle and power button, but it doesn’t seem to make a difference, regardless of if I use my old drives, no drives at all, or a brand new drive.

Any tips are appreciated.

I have the same issue happened to me a few days ago!