DROBO 5N not mounting

So, I finally got my hands on a Drobo 5N and I wanted to share my experience with everyone. I purchased it from a building material warehouse, who got it from AMAZON. He couldn’t get it to work, so he sold it to me relatively for nothing. I got it home, cut it on, updated the firmware, loaded up 2 x 2TB and 1 500GB and nothing. It connected to my network, but I couldn’t see it. I saw the IP address loaded, but the drives didn’t show up on my windows 7 64 bit system. I registered the unit with DROBO and asked for help. Unfortunately, they wouldn’t help because I didn’t buy it from an authorized dealer. I rebooted possibly 100 times, unplugged, replugged, direct connected, reset, unistalled software, reloaded software, checked router, reloaded firmware on router, changed cables, changed drives, checked software settings, etc… and I just could not get this thing to show up on the network/computer. I was about to give up and just call it a lost when I went back to computer 101. Everything seemed to be working, lights are green and nothing blinking. So I checked the LAN connection properties and I found the BIOS over TCP/IP said it was no. I remembered in computer 101 this is how the computers talked to each other. I changed it to yes and voila!!! I’m now the pround owner of a live and kicking Drobo 5N baby boy. just thought I would share that

I have the same problem. Did you connect the 5N to the network or to your computer directly? Where did you change the property of BIOS over TCPIP? Thanks.

thats good that you got it to work pipera and that you took time to register on the forum to let others know too.
(i would have thought amazon to be an authorised dealer.)

I have a Windows 7 64bit PC, NETBIOS over TCP/IP.

To enable NetBIOS over TCP/IP on Windows 7:
Click Start, and then click Network. (click Start, type ncpa.cpl into the search box for Windows 7 or Vista, hit ENTER).
Click on the Network and Sharing Center
Click Change Adapter settings
Right clicked on the Wireless Connection and selected Properties.
Select Internet Protocol version 4 (TCP/IPv4) and selected properties
Click the Advanced button under the General tab.
Click the WINS tab.
Click Enable NetBIOS Over TCP/IP.
Click OK and Exit the settings.

I did it yesterday. Still doesn’t work. I can ping it, but Dashboard doesn’t see it. Tried connecting it direct, pin hole resetting… nothing. Have a brick now…

I’m a novice in this field, but I will experiment to find the answer. I don’t know if this will help, but is your computer part of a Home Group? I made sure that I was not part of a home group, but my computers have the same workgroup. You could try that and see what happens. and In the Dashboard Preferences under Drobo Discovery settings you made sure you have a checkmark in the autodiscovery? Have you tried to look at you routers IP addresses that are loaded to see what IP address it gave your Drobo, then manually adding it to “manual Drobo discovery”?