Drobo 5N invisible to Dashboard on only 1 computer

So, I’m thinking this might be a compound issue, but the more and more I work on it, it’s looking like its not. Yesterday I reconfigured my network. Added in a new firewall and changed the subnet around a bit. (Gateway changed, DNS Changed, basically everything… :slight_smile: I changed all the computers but mistakenly overlooked my Drobo 5N. So, on my primary computer, I changed the IP scheme to match the old subnet details and such to connect to the Drobo. No dice. Searched for answers, then realized my dashboard was out of date. Updated. Still nothing (Drobo 5N was on 3.2.0 at this point, Somehow I overlooked the 3.2.1 warnings for disappearing shares.) I can ping, SSH into and Mount shares from the Primary computer, but it isn’t found by auto-discovery or by IP in Dashboard. I figure installing DD on another computer would be a good test to see if its networking related or if its something specific to this computer. Installed on a Windows 7 laptop and it immediately finds the Drobo, even though the Win7 laptop was running the new network settings. So I updated the drobos network settings and restarted it. After restart, and updating the settings on the Primary computer (Mac), its still invisible in DD. I’m thinking it might be a platform issue at this point, so I install DD on another Mac, and same as the Windows laptop, it comes right up. I was prompted to updated to 3.2.1 and I did. (Slight headache but somehow I got the Samba shares to start working again).

I’ve uninstalled, reinstalled, uninstalled again, went on a witch hunt for anything and everything relating to Drobo on the Mac in question and the installed yet again and still nothing. I can still mount drives, SSH in, etc. Just no Dashboard. This isn’t the end of the world, but I’m a little OCD about things that don’t work for no apparent reason, leads me to believe there’s a larger problem I’m not seeing.

I’ll throw another thread up about how I got the SMB shares to mount.
Thanks in advance!

One thing you don’t say is whether you are using static IP addresses or DHCP, but you’ve made big changes to your network so you might easily have overlooked something, mistyped a subnet mask, or left something out. My advice is the same as I’ve given elsewhere; break the problem down into smaller pieces. Connect the offending Mac directly to the 5N to bypass your network and you’ll have a better chance of making them work together. Check the Mac’s firewall settings. If you’ve allocated static IP addresses make sure there are no conflicts. If you’re using DHCP make sure the allocated IP addresses have been refreshed.

Is DD the same as Dashboard? I assume it is (Drobo Dashboard, perhaps?) from the context, but I’m not certain by any means.

Sorry for the missing info, I wrote that in a bit of a frustrated frenzy.
The 5N has a static IP, assigned using the 2nd computer that I installed Drobo Dashboard (DD) on. I double (and triple) checked that the Subnet mask, gateway, local DNS server, etc. were the same on all devices. Since it was essentially an overhaul, I had to do this in repetition that day, so I was extremely thorough with all the associated devices. I also neglected to mention that I tried the direct connection method, with the affected Mac, and it would not work. Also, considering the Mac in question can reach the 5N via SSH, SMB and Ping, I’m leaning towards this not being network related. It can also successfully resolve the name of the 5N in DNS. I’m thinking this is a settings issue on the Mac relating to DD, but aside from wiping the computer, I’m out of ideas.

Also: Mac’s firewall is off. I do have LittleSnitch (network filter) installed, but have went through all rules, explicitly defining allow rules for the Drobo Dashboard and all related services.

You don’t have Jumbo frames enabled on this one computer (or disabled if enabled everywhere else) do you? I hate, detest and loathe this non-standard abomination of an extension to gigabit Ethernet. The trouble it causes far outweighs the minimal potential increase in throughput it offers.

I’d like to share with you my similar experience. My Drobo 5N was visible to one of my 2 Mac computers, and I could not figure out how to fix it. Nothing I did would work, including uninstalling and reinstalling the Drobo Dashboard, repairing permissions with Disk Utility, and reconfiguring or turning off the OS X Yosemite firewall.

I finally decided to reinstall OS X. I redownloaded Yosemite from the Mac App Store, and ran the OS X Install App, which is an “In-Place” reinstall of OS X without altering your Apps or User Directory and data (with the exception of disabling “incompatible” software). The above was done following a standard uninstall of the Drobo Dashboard, by launching the Uninstall application from the Drobo Dashboard dmg window. I also had removed all remaining Drobo entries from the Firewall and the User Login preferences panels.

As soon as I completed the reinstall, and rebooted with the freshly installed OS X, I proceeded to reinstall the latest Drobo Dashboard, using a freshly downloaded DMG file. I ran the Dashboard and reauthorized the components in Firewall preferences, and rebooted my iMac.

Drobo Dashboard worked as expected. Obviously, something in OS X was restored to proper functioning, that other configuration efforts would just not repair. I recommend that the OS X reinstall be tried when all else fails, and I suggest that Drobo Support add this suggestion to its troubleshooting procedures when other steps have failed to resolve connectivity issues.

Good Luck.

For those whose Dashboard not detecting the Drobo 5N unit… but can access the Drobo 5N Shares using the Finder or manually mounting AFP or SMB… This means unit is working… just that Dashboard is having some issue discovering the Drobo 5N.

The most common issue with OSX is the OS Firewall.

  1. If you have OSX Firewall enabled. Make sure that you have “Allowed Incoming Connection…” enabled for the following Drobo related services and daemons.
  • DDServiced
  • DDService64d
  • On the safe side… Drobo Dashboard.app

After you have enabled the above… Quit the Drobo Dashboard… QUIT not close… You have to totally kill the Dashboard and launch it again. If everything goes well… Dashboard should be detecting the Drobo 5N.

*Lastly… those who has Little Snitch or similar apps… make sure you do not block the above mentioned services and daemons