Drobo 5N disk incompatibility

I have had a drobo Gen 2 for a while now, but just purchased a drobo 5n to put on my network. Once i put it up, I thought I had everything right and used a few green sata drives but I"m getting an error saying that the drives are incompatible with the firmware on my Drobo 5N. Anyone know why this would be? I have tried to see if the firmware needed an upgrade, but it says its up to date.

Did you use the disks from the Gen2 (together as a disk-pack) and place them directly into the 5N or did you use fresh drives?

I used the two disk drives from the Gen 2 first. But it didn’t work. Then I tried a fresh Disk, and I got the same message.

I just replaced a Gen2 with a 5N myself and I reused the 4 WD Green 1Tb drives in the 5N after formatting each of them. Later I bought some WD Red drives for the 5N and reformatted the WD Greens and replaced them in the Gen2 for a nephew.

After backing up the data currently stored on the Gen2, I would format each of those drives (if you want to reuse them) and insert them in the powered down 5N. When the 5N starts up it should format the “old” drives like it needs them?

Please be careful, but this is what I did, successfully.