Drobo 5n, Critical Mount Failed. Even after reset.


Went through all the recovery steps I could find, none worked, reset the unit with fresh drives and it started to reinitialize before coming back again with “Health: Critical, Mount Failed”. All lights green, no apparent issues, new drives.

Any ideas? Or is this yet another brick to add to the pile of dead Drobos I seem to be accumulating?

Edit: Latest firmware and dashboard, even did a manual re-flash of the firmware.


Few more dead Drobos, and I can make me a fort!


hi jfizer, can i check which version the drobo is showing via dashboard as the one installed?
are there any red lights on power indicator or psu?


Thanks for responding,

PSU is green, all lights on the Drobo are green and as expected. No outward indication of any problem. Drobo firmware version shows correctly in dashboard as 3.5.12, I did think I might try downgrading the firmware, but Drobo doesn’t make older versions available anymore. Unit can see installed drives, can build a volume after reset, but as soon as there’s a volume it reports that it can’t mount it.

Edit : Just found a copy of the 3.3 firmware that I ironically had stored on a non-Drobo RAID. Will try that.

Edit : Nope, older firmware made no difference. Unit reboots, gets reset, sees the drives, creates a volume, and then dies.


thanks for more info,
i think its probably best not to try downgrading anymore…as there may be some problems with that…

but, can i check if you have another computer that you could try it on? (am not sure if you have a mac or a pc, but there is a page here with some steps that might be worth checking through, just in case)
and also step 12 links through to here about some manual mounting options you could try:
and also here:

if there is nothing on those 2 drives (diskpack) that you need, (which may well be the case if you reset it), then it might be worth trying to power down completely, and then remove the drives, and to do another full reset (and then upgrading to the latest firmware, and then rebooting again to make sure the firmware was applied fully, and then to try while the drobo is running, to put in a drive, (1 at a time) and to let it recognise, and hopefully assimilate each drive in turn… then if you try a full reboot of computer, dashboard and then drobo (via dashboard’s shutdown command, after relaunching it), how do things go now?


I have tried different computers, mac and pc. That makes no difference. Likewise I have tried different drives, doing a full reset without drives first, that too makes no difference. The Drobo has no issues recognizing the drives, I can even go so far as to create volumes, it is only after that when it fails.

To be clear, your suggested steps regarding manual mounting are for mounting a working drobo. All services are shut down when this failure happens. There is nothing to mount. The error is not in mounting the drobo to the desktop, but in mounting the volume to the drobo.


ah thanks for the update, i see what you mean now,
it does sound like there is something wrong with that drobo…

if this has been happening often for you (or more often than you would like), i think its worth getting in touch with the support team, as they may be interested in, and able to figure out what is going on, from some diagnostics logs.

in case it is something with this particular unit, the below probably wont help much, though if you need some older versions to try with, there is a good link here:
(and alternative o/s versions can be found by going up a level)

i still use dashboard v2.5.3 myself, which works great across all my currently working das models, gen2, drobo-s-gen2, and 5d, (possibly also for my gen1 but that has a problem currently)[hr]
btw, is there any more info you have about the setup you are using, and the other units you had problems with?

are they all connected in some way (such as the same coomputer, cable, port, and multiplug ups or something) - am just trying to see if there is anything else that could be causing things, (or if it is just an unfotunate yet unrelated event that seems to be taking place more often for you)