Drobo

Drobo 5n - 1-4mb/sec write higher levels on read

I have a Drobo 5n that I have setup as new, however when I started copying files to it I can only get 1-4 mb/sec on the write. Once the data is there the reads are much quicker.

I have confirmed the network speed at 1000 FULL and can not find any bad packets on the network port, has latest firmware, it is a brand new volume setup after doing a full reset/erase.

Not sure what options I have for further troubleshooting - ie: ssh view, pinhole reset, etc.

Any input or advice would be greatly appreciated.

Try a different network cable or switch port.

Thank you for your response.

I have tried a few things:

  1. replaced cable
  2. changed port
  3. removed msata cache
  4. removed all but one drive in the NAS (as this was a net new build)
  5. tried mounting from a mac
  6. removed smb1 support
  7. changed MTU to 9000 and on client side

All without any impact on the performance. It remained at 1-4mb/sec.

I even spent the time to copy a file to the drive at 1-4mb/sec. It completed without issue over the course of an hour for an 800mb file. When I copied it back to the same machine it took 5 seconds (around 80/100 mb.sec) - so it is clear that this is write related.

I can see online people with 5N’s with other issues leveraging the pinhole reset. They talk about the process but I can’t find this documented anywhere. Can anyone point me in the right direction for this so I can give that a try?

FWIW - I ran wire shark on the port and found a significant number of TCP DUP ACKs. When I changed the speed to 100 FD there were much less errors and higher throughput and when on 100 HD it was even better so it is closer to what is expected for that speed.

My guess is there is a hardware issue with the card. The errors are only on the RX side which explains why the read is good and the write bad.

Does anyone have any ideas or suggestions or know where or how I can replace the card.

Thanks!