Drobo 5D won't power up

I leave my computer and the drobo 5D on 24/7. Last night the drobo was fine but today it’s powered off and won’t turn on.
The green light on the powersupply is not solid. It’s blinking about every 2-3 seconds. I don’t recall if that’s normal or if it should be solid?

If I unplug the power cord from the back of the drobo the light on the powersupply goes to solid green. Plug it back in the drobo and it starts blinking again.

Most likely the power supply is failing. So it cant give enough power when plugged into the drobo but when unplugged the light goes green because it can handle not having to actually put out a load.

I am out of warranty however I still did contact drobo support who told me the drobo is dead. I did some searching on the forums and for this identical issue other people have said it’s not the power supply.
Support offered to sell me a 5Dt with 3 year drobocare at a discounted price. Don’t really need a 5Dt as I already added a SSD to my 5D but I guess it’s better than nothing.

The green light on the power supply should not be blinking. I saw the same thing when my two year old 5D died and would not power on. BTW, how old was your 5D when it died?

2 months shy of 3 years.

This is what has me worried about the 5D. A storage device costing this much that dies in 2-3 years is not worth investing in – certainly I’m now looking for an alternative.

Yes, it is concerning. But including the 3 year extended warranty with the 5Dt shows they have more confidence in it. They offered it to me 50% off.

Prior to the drobo I ran WHS as I didn’t have to use matched drives. A couple years into that and I was having issues with a controller card and later the motherboard.

Have you tried a different Power Supply?

My Drobo Mini went down with this behaviour and I bought one of those generic laptop power supplies which have the multi voltage settings and different connections in the pack.

I set it up to match the Drobo Mini Power Supply and it’s been working fine ever since (I will say that the first time I plugged it in and turned it on I removed the Disk Pack in case it let out a whole pile of the Blue-Go Smoke).

I paid $70 (in Australia) for it so it would be a relatively inexpensive second to last resort before buying a new unit (although with an offer like that I would have probably already taken Drobo up on it).

hi there is a page here in the knowledgebase with psu info in case it helps:

This morning I experienced the exact same problem: 5D off, green light on brick pulsing, sometimes bright and sometimes dim. I have CRITICAL files on my Drobo and need them ASAP!

hi chrispaulis,
if your 5d is not powering up, it could be your psu having a problem.

i think if you can try to get a replacement psu it would be a good first test, but if it will take a few days to ship an official product, and you need things asap, (assuming it is not something else causing the issue) then maybe this page can help you to possibly obtain a compatible psu a bit more quickly?