Drobo 5D won't mount. Again!

A few months ago i reported an issue regarding my Drobo 5D, that won’t mount after i upgraded to firmware 3.2.2.

To recap:
I (thought i) upgraded to firmware 3.2.2, and after the upgrade my Drobo 5D won’t mount.
I tried several thunderbolt and usb connections but nothing happens. I even powercycled the Drobo and the MacBook, reinstalled the Dashboard, disconnected the HDDs…
The Disk Utility doesnt recognize the Drobo either.

Nothing helped. Then, after several power cycles, reconnections, suddenly the Drobo did mount. But to my surprise the firmware was never upgraded and after this incident i decided not to upgrade it, since i was finally able to see and work with all my data.

So i used the Drobo for a while now. Everything seemed to work just normal, but now i have the same problem again. But this time, i didn’t even tried to upgrade the firmware. The last time i used the Drobo everything was shut down properly and still all the lights of my Drobo are green. The Problem still remains… There is no difference, if i try an USB-Cable, or a Thunderbolt Cable. No Port works, even on two different Macs.

During the last years, it happend from time to time, that my Drobo wasn’t recognized, but usually all i had to do was unplug the thunderbolt cable, then plug it again, and then it mounted.

In my opinion, it couldn’t be anything else, then a hardware problem, maybe a loose contact on the Drobo, but it applies to both thunderbolt and the USB connectors.

If i had any chance to get to my Data thats stored on the Drobo, i would backup everything, and sell the Drobo. I never had any Problems connecting any device in my life, besides this Drobo. And as a filmmaker/cutter, i connected lots of drives.
Is there any Support in Germany? Can i send my Drobo somewhere without my HDDs in it, and can i still use them, after they fixed this Problem? Or has anybody any other idea what to do, since i tried everything over and over again?

It is impossible to work with this thing, if one can’t rely on it…

sorry for my english, i hope it’s still understandable…

hi philip, i remember your post before :slight_smile:

did any of the suggestions from several users help at all?

unfortunately no… nothing helped. the drobo seems to work fine regarding the leds, but it is just not possible for me to get any access…

oh ok, maybe we can try again here some similar or new ideas…

can i check if you are currently in warranty with your 5d? if yes, then i think it is good to raise an official support ticket in the system, as the support team might be able to see what the problem is from some log info.

what happens if you shut down the computer and the drobo
and then unplug the power cable and connection cable (for example usb)
and then remove all drives (remmebering the order position)
and then plug power back into the empty drobo, and power up the drobo
(does it boot up and then go into standby mode?)

if yes, can you now power up the computer
and when computer is powered up, to plug in the usb cable to connect computer to drobo,
(does the drobo wake up?)

if yes, can you open dashboard (which version do you have now?)
and can dashboard see the drobo?

(important: the drives inside your drobo are the diskpack…please only remove all diskpack drives when power is off, and if you want to put the diskpack drives back they should only be put in when power is all off)

The above test, is to see if your computers dashboard can recognise an empty drobo. (if the drobo is wokring fine, and if the power supply is also fine, then as far as i know the dashboard should be able to find it… if dashboard runs successfully, but can not find the drobo, then there may be a fault with the drobo… but please try this test and we can carry on over time with some other thoughts for you)[hr]
also, if you know a friend with a computer or if they can bring their laptop to your house, it might be good to try to connect your empty drobo with their computer, and using their usb cable as well if possible, just to see in case it is recognised by dashboard on their computer…just in case something on your computer is possibly conflicting?)

Hi Paul,

sorry i got no email that you replied again… I tried your first steps

“what happens if you shut down the computer and the drobo
and then unplug the power cable and connection cable (for example usb)
and then remove all drives (remmebering the order position)
and then plug power back into the empty drobo, and power up the drobo
(does it boot up and then go into standby mode?)”

after that the 1st led of the drobo is red. if i plug in the cable to my mac, nothing happens. dashboard and finder dont find it. The Drobo Dashboard Version is 2.7.1 [78171][hr]
Hi Paul, it’s me again…

though the steps you described didn’t help at first, i just rebooted again with all my drives plugged into the drobo, and guess what? it works again!

i don’t know if you wanted it to work that way, but to boot the drobo without drives and plug it in, out and power cycle it seems to work like kind of a reset… or… maybe it’s just coincidence… i don’t know… but i guess i will find out, next time my drobo is not recognized properly.

anyway. thanks a lot for your time and help!

thanks for the update, am glad its working again for you
(i think its a little bit less of a coincidence :slight_smile:

Hi guys,

I have a similar problem with my 5D. It just won’t mount anymore. I tried it on my mac and pc. I tried the suggestion above pulling all drives and starting it up again empty. It is then actually recognized right away with the message to add a drive. Once I power it down, add the drives and reconnect everything it doesn’t show up anymore.

I tried all other suggestions from the official troubleshooting and forums but nothing worked so far. If you have any other ideas please let me know!

Thank you!

hi Janurschel…

need more info… to determine what the issue.

  1. Seems like the unit is working fine without drives… which is good.

  2. When boot up with drives, is all the DRIVE BAYs RED??? Or is all GREEN?

ALL RED - likely to be a Disk Pack issue…
ALL GREEN - Drives or Disk Pack are ok… firmware has booted… But Drobo Volume not mounted on Windows or Mac… This likely to be a filesystem corrupted…

*If all the Drive Bays are GREEN, Dashboard is able to detect the 5D. But OS not mounting the volume. Try these:

a) If you are on a MAC OSX… and is using Thunderbolt, try USB 3.0 instead. To confirm is not a Thunderbolt port issue. Or the other way round…

b) If both USB 3.0 or Thunderbolt is NOT able to mount… and you are on OSX… and if you have DiskWarrior. Try using it to check and repair the Drobo 5D HFS+ volume.

Thanks for the quick answer.

All lights are green and capacity indicators also show the right amount.

The empty drobo mounts fine via usb, but full it mounts neither on usb or thunderbolt.

I’ll try disk warrior and get back to you.

great… looks like a file-system issue … hopefully DiskWarrior is able to fix it.

OSX Disk Utility repair is not as powerful as DiskWarrior, thats why I recommend to try DW.

DW is also quite expensive. :slight_smile: Before I fork money out for that, will DW be able to recognize the drive even if dashboard, finder and Disk Utility don’t??

Firstly… open OSX Disk Utility

Do you see a Drobo Device listed in Disk Utility … under this Drobo Device… there should be a partition… which i guess in this case is grey out and not mounted.

Do you see it?

No, there is nothing in disk utility.

Now the empty drobo doesn’t even show up anymore …

Can be more specific?

Boot a empty drobo 5D without drives…

  1. Did it boot up properly showing you the TOP MOST drive bay RED?
  2. Did the Dashboard detects the empty 5D and prompt you to insert drive…

*If both are YES… then means unit is ok.

**If TOP MOST empty drive bay is RED… the rest are no light BUT Dashboard is not detecting …liekly be a detection issue with the USB or Thunderbolt connection.

  1. BUT if you boot the empty Drobo 5D without drives… and it stuck at all empty drive bay RED… then the unit maybe at fault.
  1. YES
  2. NO

Just did a pinhole reset on the empty drobo … no change

In this case, the Drobo 5D unit is ok…

Just the when connected via USB or TB … the Dashboard is not able to communicate to the 5D thus not detecting the empty unit… and prompt you to insert drive.

  1. Down down the empty Drobo 5D…
  2. Connect it to the MAC using USB 3.0
  3. Make sure power is OFF… insert all the drives back into the 5D.
  4. Power up… the 5D with drives…
  • You should see it boots and all drive bay GREEN… OSX not mounting the Drobo Volume in Finder and desktop.
  • Dashboard may or may not detect the into… which is ok …
  • With all drives in 5D… GREEN. Disk Pack is ok…
  • Now open OSX Disk Utility… did you see on the left panel of the Disk Utility …a Drobo device… and also under it… a grey out partition…??

Ok so this new tip helped. Its working again but strangely enough without the capacity indicators on at all. At least I can get to my data again … will need to run a few more tests to see if I can find the problem.

Thank you so much! I just don’t really understand why it just worked. :slight_smile: But awesome! You really helped me out with this one!

After each reboot of any Drobo … the Blue Capacity light takes awhile to fully reflects the actual disk space usage in Drobo. Basically the firmware needs some time to calculate the disk space usage.

Wait awhile… and check if the Blue Capacity lights slowly … lights up to a level that correctly reflect the usage.[hr]
by the way… are you connected using USB 3.0 to a Mac? IF yes… can are you using the bundle USB cable that came with the Drobo 5D?

hi janurschel, am gald that the recent posts with don.esc have resulted in things working for you again as well.
from reading your latest post about doing some tests to pinpoint the problem, if your drobo is stable again then i would like to suggest that you make some backups of your data if possible, before trying any more troubleshooting, just to play safe :slight_smile: