Drobo 5D wont connect

Im having issues with getting the Drobo 5D to connect with USB, Im getting the confirmation sound from windows 7 64bit but nothing shows up in the dashboard (everything is up to date) i used several usb connections including the built in ones on the motherboard and also add in cards. all looks good in control panel with no errors showing although i do get pop up showing unknown USB device under "renesas Electronics USB 3.0 hub (not a hub its an add in card) the card works fine with other devices. as a side note i have also deleted/uninstalled all usb devices in the control panel and let them re install.

After you plug it in and hear the confirmation sound, how long do you wait. I had the same problem but I noticed if I waited a bit it would eventually show up.

lets call it three days now, im totally baffled since everything is green on the drobo 5D and i have also reversed trying to set up and still get a “looking for connected drobos”

I purged all my USB devices (completely deleted them from device manager) and let them re connect and find new drivers if needed also downloaded latest MB drivers from MSI via the Live update. Im very baffled since all my other usb devices work fine.

even though windows says it connected via the audio que the dashboard is not seeing it as so :o( I have also manually installed the MSI USB 3.0 drivers instead of letting the MSI driver panel do it.

I just put in a ticket for this issue. (im pretty sure its driver related even though i have never seen one act like this before)

[quote=“DSLAM, post:2, topic:140477”]
After you plug it in and hear the confirmation sound, how long do you wait. I had the same problem but I noticed if I waited a bit it would eventually show up.

What version of Dashboard?

2.6.4 [72278] I was just able to access the drobo with my windows 7 laptop, at first it did the same thing as my desktop machine but thing was able to install the driver (my laptop only has USB 2.0) so clearly its an issue with USB drivers but at a loss for resolving

its a driver issue, the USB driver fails to load after you hear the windows clunk/clunk, a little ballon pops up on the right. everything is up to date and i even tried unloading (removing/ uninstalling ALL of my usb devices and doing a major house cleaning of all things USB. I should probably list all my hardware here.

well i think i fixed this issue in a really weird way. after trying to get this thing to connect via every USB socket on my computer along with removing all my USB drivers letting them reconnect/install and nothing working i was at a loss, I just so happened to have ordered a nice metal box 7 port USB 3.0 Startech powered hub which i plugged into my front panel usb port (i have 4 of them USB 3.0 powered by an internal card that also has two back ports also) again i got the windows clunk/clunk install but this time the DROBO panel came to life. (i should note that i hadn’t even plugged in the power cable for the hub yet either) … I would call this very strange since i have worked on VERY large storage units in my normal day job … not sure if the above helps others?

I also cannot connect my Drobo 5D to my windows 7 desktop using USB3. However, if I connect it to USB2 on the same machine, it works.

try a USB 3.0 hub plugged into a USB 3.0 port on the computer, why this worked on mine i have no idea? i have mine plugged into a 7 port powered Star Tech 3.0 hub
I have yet to write to Drobo how i was able to finely connect, my first two contacts with them were pretty much the run around. im pretty sure the Network versions of there products work much better and i almost got that but thought do to my photo editing and other duties USB would be best. and the fact that im an MCSE and know some of pitfalls that could happen.

I also had that same problem. This is a problem with Drobo as they seem to be behind in their Windows USB 3.0 support. Hopefully it will get better going forward.

very weird way around the problem, it was pure luck that i plugged in that hub and it decided to register. so dont give up, now about those 6TB NAS drives??? LOL (correction: I see they support 6TB drives no problem) by the way if you have an mSATA card install it, it makes a HUGE difference in performance its like having a super fast buffer for your data before it gets written

My Drobo 5D worked fine on USB 3.0 before I installed the latest firmware. Does anyone know when the previous firmware updates are located. I’d like to back to whatever was before 3.1.2

I wouldn’t recommend that.

I would hit Drobo care hard even though there questions can be VERY annoying, be sure and list all the things you have done as far as making sure you system is up to date, also try going through a hub like i did, its weird that i had to do this, a 3.0 hub attached to a 3.0 socket in my computer? why couldnt i just plug it in directly? Messed up huh?