Drobo 5D won't connect and then turns off


I’ve been struggling with this Drobo for a few weeks now trying to understand what is going on.

This is being used Time Machine backups on an internal Mac mini that is running 10.9.5. It’s connected by Thunderbolt.

A few weeks ago my users got message about them not backing up in a while so I checked the server and it was on but no Drobo connected. Checking physical state, the Drobo seemed to be in “standby mode” where a lights besides the power light is off. Power light is an amber/red type colour (but green when on).

So I powered it back on, and it seemed to start up nicely but it still would not connect to the computer nor show up in the Dashboard. I also could not see it in System Report.

Since, I’ve been trying many things to try to isolate the issue. Here’s what I have tried:

  1. Tested both thunderbolt ports (on Drobo and Mac mini)
  2. Tested with another computer.
  3. Tested a different thunderbolt cable.
  4. Tested with a USB cable (but I only had an older USB1/2 cable)

Drobo powers up, but will not show any signs of connecting and after a while seems to go into that “standby mode”. Is that expected behaviour, by the way, that it goes to standby of no computer connects?
Because that seems reasonable.

What’s more: On that server I am using an old display connected via miniDisplayport on the back of the Drobo and the display works fine, when Drobo connected via Thunderbolt. So, the cable and ports seems to be working.
I have of course tested this without the display connected, which was also done when I used another computer (MacBook Air).

As you can imagine, this server is not updated anymore, so there has been no change in software that could have caused this and I have tried this with in total 3 computer running 10.9, 10.15 and now with my Mac Studio running macOS 12. Same result.

Also, I have a personal Drobo (4-bay Firewire) that recently behaved weird and there I figured out it was the power supply. I used this Drobos power supply to troubleshoot (since it was not used) and that’s how I figured that out.
But I also saw that the 4-bay power supply outputs 7A but the 5D outputs 10A.
So even though it solved the issue with my 4-bay, could this be power supply related? Like, it outputs enough for the 4-bay but not for the 5D?

If you have any input, that could help me figure out what’s wrong, I’d appreciate it.

Thank you for reading this far.

The next check is your 5D power supply.
Purchase new (non-branded) from Amazon and make sure you plug it direct into a wall outlet.

EDIT: If this does not work, the file database on the Drobo could be corrupted. This will necessitate
you purchasing DiskWarrior to trouble-shoot and rebuild the database if it is HFS+ (but not APFS). DW has the ability to ‘find’ and recover lost volumes. The only other issue is that DW is not (yet) compatible with the current MacOSs and it needs to be installed on an older MacOS therefore check the website to ensure you have a compatible Mac + MacOS to use. This has been my ‘Go To’ for a similar issue, and I have an older Mac laptop that is designated as my rescue Mac with DW installed for exactly that purpose which I run each each half year to rebuild the file database on my Drobo 5Dt.

Let us know how you get on.

Same thing happened to me and found out it was the powersupply, very low output, so not even the fan turned normaly, it just flicked back and fore.

Had to order from USA so it got very expensive for me, but at least it works now.