Drobo 5D won't boot

My Drobo 5D just lights up 5 yellow lights and sits there forever. It does this with or without the drives in. I also have a Gen2 Drobo so I tried the power supply from that one and it doesn’t make a difference.

I have my Drobo attached to a Mac Mini, with everything behind a UPS. I experienced a momentary power failure, and despite the fact that the Drobo was attached to a UPS, the power loss seems to have fried my Drobo. My Mini didn’t even shut off.

Does anyone have any idea what’s wrong, and how I can get my hardware working again?


  • Andrew.
1 Like

hi andrew,
am not sure if you are still in support (possibly not, though if you are i would raise a ticket for the support team)

for the current issue though, can you see any lights on the drobo for power (and also on the psu brick) to see if they are showing or flashing any colours too?

(am not sure if the gen2 psu is fully compatible though there is a page here with some more info in case you are able to try with another compatible psu just in case)

and some more info here in case there is a red light it could be overheating too?

can dashboard still recognise the drobo? if that can no longer see it, then it could be that the main unit has a problem (though is worth trying another psu as well, just in case the gen2 psu doesnt have enough power for it)

if it is just the hardware, and if the diskpack is ok, then the best way to get access to the data again could be to try the migration process, with a replacement compatible model, for example as mentioned here:

(when my drobo-s-gen2 had a faulty power switch, i was able to successfully migrate my diskpack and access all data again.)

Thank you very much Paul. My Drobo is out of support. I tried asking support first, but all I got was a form response about how I could buy a support ticket. The link in the email didn’t seem to work. My username is “AndrewClarke3” because over the years this is the third account I’ve had to create on these forums as their migrations keep breaking my accounts here. I wrote them back, asking more precisely for help and I got the same form response back. I kind of hit my breaking point on that and sent them a response letting them know just what I thought of their “buy a ticket” form response when the link in the response doesn’t work, and their “ask the forums for help” response when my TWO accounts don’t work on the forum any more, and they just closed my question as “resolved”.

AHA, I just found out how to buy DroboHelp. I just hadn’t clicked around drobostore.com enough. I’m going to buy a ticket.

In the meantime, I’m pretty sure I have a hardware problem with my Drobo. The blue lights come on momentarily on the bottom, but then I’m just left with the five yellow lights along the side. There’s no red light anywhere, and it doesn’t seem to boot up enough to register on the Dashboard. If anyone has any ideas, I’m interested in hearing them. I’ll also report back once I’ve spent my $49 and see if I get any useful help from it.

thanks andrew for the info,

(ive been in the same boat with regards to other companies and policies, like getting locked out of 1 of my gmail accounts, which i dont know how to get back in, and when a 2nd one still works, and also losing a Discord account where they wouldnt even read the proof i sent them and closed the ticket and the ‘ticket system’ had the cheek to ask for a rating of the support :smiley:
(if google and discord see this please get in touch - slightly annoyed but polite rant finished) :slight_smile:

for your current drobo-related issues though, please let us know how things go