Drobo 5D Thunderbolt Not Connecting

So, I just picked up a TB cable for my Drobo/Mac Pro. It’s connected, and I can see under the OSX system profile (Hardware>Thunderbolt>Thunderbolt Bus>5D), where it shows that there is a Drobo 5D connected. Unfortunately, the Drobo Dashboard simply fails to find it. I end up with “Looking for connected Drobos” indefinitely.

It connects fine with USB 3.0.
Yosemite 10.10.2

Any suggestions?

These articles should be of some help:


Thanks for the suggestions…
No luck yet. My firewall is actually already disabled.
All software/firmware up to date… Any other possibilities?

Check this Knowledge Base Article:


I have not been able to get my Drobo 5D to connect with either Thunderbolt or USB 3.0. Any other suggestions other than the three listed?

Having the same issue smh

hi, just to check… for those who have not been able to resolve the connection problem, via those 3 website links, i was wondering if you can try with another cable just in case the physical cable happens to have a problem too?

it might not fix it, but for others in the past - it turned out that their cable had a problem too :slight_smile:

Yes. I tried different cables from Thunderbolt-connected devices that are working.

thanks reuben,
can i check how many different usb ports your mac has, and if you have been connecting directly from the 5d to the mac or have you been going through any passthrough connectors or adapters etc?

also have you tried all usb ports that your mac has?
could you also try another usb cable (just as you tried a different fireware cable just to see?)

It is a brand new Mac Pro with four USB 3.0 ports. I have tried all of them. I am connecting direct to the Mac from the Thunderbolt and USB connections. I have tried multiple cables as well, including a Thunderbolt cable I know works with a different hard drive unit.

ok thanks reuben,
can you confirm which dashboard you are using when you get a moment and which firmware, and which mac os?

OS X 10.9.5
Drobo Dashboard 2.6.9
I don’t know what firmwarm I’m on since I can’t connect…

thanks reuben,

i was wondering if you could try the following when you have a chance…

  1. to try the drobo on another computer (or a friends) just to see,
  2. i think your drobo is empty? but if not what colour are the all the lights, including powerlight when you plug it in?
  3. depending on the colours, such as red power light for example, and if it doesnt get recognised on another mac/windows computer or with dashboard, then it might possibly need a replacement. (a rare thing but possibly damaged in post)

Has anyone developed a solution to the lack of ThunderBolt connection for the 5N and/or the Mini?

Adding to quest for a solution . . . Late 2013 MacPro running 10.5.5. A Drobo Mini and a Drobo 5D were both running nicely directly connected via t-bolt to two of the MacPro’s native T-bolt ports. OS hiccupped and was re-installed. Now the two t-bolt Drobo products (above) will not connect via T-bolt. Both work fine using their USB ports. Both connect fine via T-bolt to Macbook running same OS, so the Drobo hardware and the T-bolt cables are eliminated as source of the problem. PRAM reset does not fix it. Re-install of Dashboard 2.6.9 does not fix it. Safe shut-down and restart does not fix it. Dashboard continues to see and deal with other Drobos online - an iScsi connected Drobo Elite, an old Drobo 2nd gen connected via USB, and older FS and a 5N on the LAN all functioning normally. MacPro’s system report sees both T-drive Drobo’s on their separate T-bolt busses. Each of those T-bolt busses are known to work (displays connected). Mac’s native Disk Utility does NOT see the two T-drive Drobos. I don’t even want to get into it with Drobo support because even though the Mini and the 5D are Drobo’s latest and greatest, they’re almost a year old and out of ‘warranty’.

Has anyone developed a solution to the lack of ThunderBolt connection for the 5N and/or the Mini?

hi, is there a way to unplg all, and then to try rebooting and attaching just 1 at a time, building up to get your 5d and mini as you had it before when all was working, and then adding the others if it works? maybe all at the same time is causing some confusion to the reinstalled system?

I’ve tried just about everything I can think of short of retrograding firmware and the MacPro’s OS; which is not going to happen. Swapped T-bolt cables. Tried after updating to 10.10.5. Tried rearranging T-bolt connections on the MacPro; tried t-bolt ports on back of Apple t-bolt displays; nada.

All is well on USB; t-bolt fails without comment. OS sees the mini and 5D T-bolt connections within ‘About this Mac’ system report; just won’t mount; not seen when native Disk Utility is run. No disk activity light at all through boot and shut-down when connected via t-bolt.

Symptom ? : early on, when the t-bolt connections were working great on the 5D and Mini, both devices would go to sleep when the Mac was put in sleep mode, AND both devices would go to sleep when the Mac was shut down. Now, under USB, both devices sleep OK when the Mac sleeps (as before), but now when the Mac is shut down, both the Mini and 5D remain ‘active’, i.e., not in sleep mode, with all display and status lights lit. Can’t tell if the drives spin down eventually after shut down.

Editorial: It really is a bit sad that Drobo abandoned a pool of serious business users who were talked into using these fascinating devices for the few years they were actively developed; many of us are stuck now with tons of data and a dilemma related to continuing to ante-in to what appears to be an end of life situation for Drobo. The cost of switching to Qnap or another more actively supported feature set is the goal here for this year’s tax season.

It’s possible there’s some kind of conflict within the arrangement of 3 t-bolt displays connected to the 3 t-bolt buss ports on the MacPro, but I can’t find any documentation on this. Anyone? Drobo (or whatever your’e calling yourself these days)? Apple? Bueller?

Again, late 2013 MacPro; 32Gb ram; 10.10.5; Dashboard 2.6.9 [74648]; and they worked just great on T-bolt 10.10.2 - 10.10.3.


GOT IT WORKING but it wasn’t fun and from an end user’s perspective, not at all aesthetic . . .

Along with the iScsi voodoo DROBO introduced many of us to (then in early 2015 revoked the driver in support of ATTO, a la screw you, end users), there’s this OS kernel extension called drobotbt.kext that I just found (maybe I missed something in an earlier post?). Anyway, it was apparently this little devil that somewhere along the way became corrupt, misplaced or otherwise pissed off enough to cause the system to loose thunderbolt connection to the mini and 5D that had to be switched to USB. During a reboot, just before the logout, a message flashed no the screen : “library/extensions/drobotbt.kext installed incorrectly” Ah! Drobos are apparently NOT industry standard thunderbolt devices and require a driver. Nice to know 3 months after the incident. Thanks again Drobo / Disconnected Data.

hi its cool that you managed to get it working again.

where was that file btw - was it on the main mac operating system drive? if so, i was just thinking if it could be possible that somehow the main operating system filesystem maybe needed a mac equivalent of a chkdsk/scandisk, and that maybe somehow that was causing the initial problems?

eg sometimes on windows something can go wrong and needs a scandisk etc.