Drobo 5d Stopped Working - no power

I have a Drobo 5d 2014 that has stopped working. I checked the power brick and there was no 12v output. Changed the power brick for a new Drobo one, connected to my 5d, but Drobo still not working (no lights, no fan, nothing).
I have all my business backups & personal file archive (DevonThink) & photos & webstore images etc on it and don’t know what to do next. Out of warranty, and no real help from Drobo team (apart from buy a new Drobo). The machine is 2014 model, so not old. How do I get it fixed? I am based in Switzerland. Thought Drobo was magic, but now that I have problems and no help, starting to understand why nobody else I know is using them.
Is the only way to get the information off my HDDs by buying a new Drobo?

If you are trying to change to a power brick (PSU) from another Drobo, make sure is from 5D as well. As the power brick from older Drobo model such as Drobo Gen2, DroboFS or Drobo S may NOT work on Drobo 5D. They might be under power and not providing enough power to start up the 5D.

If you are sure that is a faulty PSU, you can visit Drobo.com … their Official Europe online Store and order the Drobo 5D Power Supply Unit for 79.00Euros include VAT.

Thank you for the answer.
The problem is not the Power Brick as I have bought and connected a new one (for the 5D). The problem is the Drobo itself will now not start up - no lights come on, no fan, nothing. Is there an internal fuse on the Drobo? or a cut-out switch? The problem occurred at the same time as the old Power Brick stopped working.

(hi am just linking to your latest post here plivett)

Sep 2016: Is your problem fixed? Is your Drobo 5D now powered up and how did you fix it? I am interested because I seem to have the same issue; My 5D is from early 2014, never had any issues, two days ago the 5D unit does not power up anymore. The original PSU is fine as it provides 12V output to the 5D. I am waiting for a reply from the Drobo support team. If you have any updates that would be much appreciated.

Hi, any news about this issue ?

Same prob with a 5N…

; )

hi guilain, there is another post from svissers here too, and some more info about power psus too:

am not sure if you are still in support, but in case your power supply is having a problem, maybe you could try with another psu in case the main drobo unit is ok?

if you can see a red light though, it could be an issue with overheating, for example as mentioned here:

This exact thing occurred to me overnight. When I came computer, I discovered that my 5D had lost power. I tried the plugs and found that it will not power up. The indicator light on the brick is pulsing green, but with varied brightness, so I don’t know if that means anything.

hi chrispaulis, just linking to your other post here with suggestion for you: