Drobo 5D not recgonized when in USB 3.0 Ports

So I recently got a 5D from a friend and I can’t get the 5D to show up in Device Manager or Drobo Dashboard when it is connected to a USB 3.0 Port, but it works on USB 2 ports.

The Drobo (3.5.2) and dashboard are fully up-to-date, I have manually updated the firmware (even though it was the current version), tried 3 different USB 3.0 cables that all work with other products, 4 different computers, tried on 2 Windows 10 PCs, 1 Windows 10 laptop, a Dell R710 (Server 2016 DC) with a USB 3.0 PCIe card (renesas chip) and updated all drivers.

The Drobo works fine plugged into all USB 2 ports when using any of the 3.0 cables. When it is plugged into a 3.0 port, the Drobo’s lights turn green after a few seconds, but it never is detected by the OS or the dashboard. Does anyone have any ideas or suggestions?

Looks like there’s a manual update to the Dashboard to ver3.0.1 to fix a discovery bug.


It looks like this is only for MacOS, not for Windows unfortunately. Though it does give me the idea to try an older version of dashboard for the heck of it, even though it does discover my Drobo when in a USB 2.0 port.

hi it might also be worth trying to shut down the computer, and then the drobo (which may go to standby mode)
and then to unplug the connectin cable from the computer and to wait with all off for about 5-10minutes…

if you then power up the unconnected drobo (even if it has its own part of the cable attached to itself), it should boot up as normal with the blue lights sequence, and then go into standby mode.
and then if you can try powering up the computer, and launching dashboard,
and then to connect the usb cable to the computer, what happens now?
(does the drobo wake up shortly after, and then become recognised by the computer and dashboard?)

i had some problems in the past (but a few times overall) on windows, where my ports became locked, and this was just due to swapping a few different usb things in the ports, (even non drobo usb sticks etc), and then after trying the above it worked ok.