Drobo 5D lost usb connection after firmware 4.1.2 update

I updated the firmware on Drobo 5D from 4.1.0 to 4.1.2 a couple of days ago. Since then I have lost the ability to connect via USB 3. Lightening cable/connect still works fine. I’m work on Macbook Pro with system 10.10.5. I have tried changing the USB ports and USB cables … USB connection no longer works. When I unplug the cable and replug the USB cable back in the Drobo 5D acts likes it going to mount the drive (lights blink and reset), but the drive does not mount. The drive does not show up as a disk to mount in Drobo Dashboard, or Mac OS X disk utility (when USB cable is connected). Will there be another firmware update coming? Can I go back to firmware 4.1.0 … is that not recommended? … if so, where do I go to download the file?

I have this exact same problem as well. You didn’t mention which version os OSX you were running but mine is Yosemite 10.10.5.

The Drobo was running fine until the firmware update and after it nothing sees it.

Don’t suppose there’s been any update on this issue from anyone (sorry to bump if this has been solved elsewhere)


Sorry - no update that I can see… :frowning_face:

I’ve raised it with Drobo support, who said they didn’t know about the problem but they’d escalate it with engineering. TBH, I don’t hold out much hope…

I have found that I can get a reasonably reliable connection by unplugging the USB before turning the Drobo on, then only plugging it back in once the Drobo has booted (but before it goes to sleep). After about five minutes (and seemingly a few more reboot loops of the Drobo), it seems to mount.

For the record, I’m running macOS 10.12.6 on a Mac Pro3,1 (i.e. USB2.0 only).