Drobo 5D disconnects, drops during file copies, etc...

Hi everyone,

I recently ordered a Drobo 5D with 5 Seagate 2TB NAS drives (a bundle offered by Tiger Direct), and also added a Crucial M500 Series 240GB SSD (mSATA) for cache.

My intent was to use the Drobo 5D to replace the plethora of USB attached drives that I use for Norton Ghost backups, VM images, software installers, etc…

My computer is a Lenovo ThinkPad W530 laptop with a Mini Dock Plus Series 3 with USB 3.0 - 170W docking station. The machine is running Windows 7 Professional 64-bit, and is as patched as possible. I have a number of USB 3.0 drives that all seem to work fine through this setup.

From day 1 when the Drobo arrived, I had problems. On my kitchen table, using the laptop only, I assembled the Drobo and connected it to the laptop for setup and had problems where it appeared that only one of the two USB 3.0 ports would allow the Drobo to be detected. I finally managed to configure it and put it aside until I could properly find the time to install it on my desk with the rest of the equipment.

I have tried to connect the Drobo daisy-chained off of an Ultra USB 3.0 hub which was attached to my docking station’s only USB 3.0 port. No joy, windows reported that the “USB Device Not Recognized”.

I attached the Drobo directly to the docking station’s USB 3.0 port. Again, windows reported that the “USB Device Not Recognized”.

I attached the Drobo directly to the laptop using one of the USB 3.0 ports (which I remember now was the one that didn’t work when testing on my kitchen table). Again, windows reported that the “USB Device Not Recognized”.

Finally, I attached the Drobo to the USB 3.0 port on the laptop that HAD worked before, and up she came. I was irked by having to connect not through my docking station, but thought to see where this took me.

I attempted to copy several virtual machine files (about 30GB each) from my WD My Passport USB 3.0 drive to the Drobo. Each and every time that I do, the connection gets reset and the copy fails. Once, I decided to watch the copy, and I watched the throughput drop down to 65MB/Sec… considerably slower than USB 3.0 speeds.

I have read that there are known issues with USB 3.0 drivers and chipsets with Drobo 5D, and am hoping this does not mean I have to return it. The hardware is nicely designed and I like the idea of the Disc Pack and extendable storage, but it has to be a reliable solution. I am an enterprise software development consultant, and I simply MUST be able to rely on my backups.

Has anyone else seen this behavior? Do you have solutions?

Not much help on your specific issue im afraid, but some general observations on USB 3

its fast and buggy, lol!

I have a Lenovo Yoga 2 Pro, with a sole USB3 port

a bunch of my peripherals wont work off that… but if I plug that into a USB 3 hub, then they work via the hub (but not direct)

My Drobo 5D wasn’t detected by it, or by the USB 3 hub built into my monitor (at all - not just not USB2)

it WAS detected by a USB 3 port on an Unpowered hub hanging off the back of the monitor hub

and also by the desktop I am currently using it with

my point was more that I’ve had random compatibility issues with several USB 3 peripherals, not just the 5D

I had similar problems on my Windows machine with USB 3.0 as well. I was like you at first, it seemed that it was always saying “USB device unrecognized”.
I’m still using it and here’s the conclusions I’ve come to.

Drobo support for USB 3.0 on Windows seems to be very limited. The Drobo seems to be very picky about what USB card and drivers you are using.
Also, I realized that it seems that Drobo needs some time to get recognized by windows. I found out that usually when I first plug it in, it will almost always say “USB device not recognized” but if I leave it plugged for a few more minutes it eventually does recognize it and everything is very stable from there on. Indeed, when I first got mine I was wondering if I was also going to have to return it but it has been flawless other than the USB pickiness.
Also, even with USB 3.0 it’s still not as fast as it could be. Drobo needs to go ahead and implement Thunderbolt on Windows now. There’s really no excuse at this point.
Lastly, I also had one port on which the Drobo works but easily looses the connection, other things dont seem to have this problem on that port. I now never plug the Drobo into that port, the other ports are always fine.

So first thing to do is make sure you are using the latest drivers for your USB card and then make sure you have the latest firmware and dashboard updates for Drobo. Then choose a stable USB port and see if it eventually works.

Hi everyone,

Thanks for the feedback.

I have since found that my ThinkPad does have an available update for USB 3.0, so I have installed it.

After doing that, suddenly my Drobo was no longer being picked up on the port I had originally had luck with. So on a complete whim, I tried the port on my docking station and it connected… um, okay…

That being said, transferring VM images from my WD My Passport USB 3.0 to my Drobo I am getting a lightning speed of 19.5MB/s…


Considering I can copy to my local drive from the same WD My Passport and get MUCH faster speeds, I have no doubt the issue is with the connection to the Drobo.

I’ll keep updating as I keep experimenting.

Hi everyone,

More news. I have a Kingston DataTraveller Ultimate 3.0 G3 128GB, which I have connected to the same USB 3.0 port that the Drobo has been for the previous post. I have attempted to copy a 30GB file from the same USB 3.0 WD My Passport to this DataTraveller drive, and noted that I got speeds ranging from 19.9MB/s to 30MB/s. Considering this is a flash drive, and the Drobo is running 5900 rpm NAS drives, I guess I can see the reason for the speed difference.

So this leaves me wondering if the docking station’s port is just slow. Next I’m going to try the same experiment using the laptop’s other onboard USB 3.0 port.

More news later.[hr]
Identical results on the other onboard USB 3.0 port.

I use Parkdale for these kinds of tests. You can get it here: http://thesz.diecru.eu/content/parkdale.php

[quote=“anthonyneal, post:5, topic:139689”]More news later.[hr]
Identical results on the other onboard USB 3.0 port.

Sounds like your USB 3.0 ports are running as USB 2.0, which probably means the driver is missing/incorrect, or your USB cable is faulty or not USB 3.0.

USB 3.0 is USB 2.0 + extra pins. If the extra pins are faulted, it’s still possible that the device runs, but in USB 2.0 mode.

Can you check Device Manager and see what USB host controller drivers are listed?