Drobo 5d and pci-e USB3 not so good

We just recieved our drobo5d and an inateck usb3 pci-e card. ( http://www.inateck.com/inateck-ktu3fr-2o2i-usb-3-0-pci-express-card/ ) The inateck uses the FL1100 controller. We have installed the newest drivers and hooked up the card using the molex to sata power adapter.

The Drobo is connected using the usb3 cable supplied. WE HAVE TRIED ANOTHER USB3 CABLE AS WELL :slight_smile:

The problem is that whenever we try to transfer files bigger than lets say 100mB the drive just dismounts and then reconnects. If we try using the onboard usb2 then everything is fine.

I moved the Drobo to another computer with USB3 onboard and there it doesn’t complain! It works just fine.

We tried the usb3 pci-e with another usb3 harddisk drive and that works just fine. So the PCI-e card works but just not with the drobo.

Is the drobo really that picky with USB pci-e cards?

Any hints on how to fix it without buying a new USB3 pci-e card?

It’s an old x58 computer with p6 deluxe v2 motherboard, 24gb ram, Core i7 950 cpu. PSU is a hx850 from corsair. Running windows 8.1 pro. it’s meant to act as a server for us at work.

By the way the drobo dash software says that it is up to date with the latest firmware. yeah and I checked this already.

I had some similar problems with USB 3.0 on my windows machine as well. I dont know if the problem is with Drobo or not but it does seem to be more picky about USB controllers than any other product I have used.
I know there is an approved list of USB 3.0 card controllers on the Drobo support site somewhere but I’m afraid I dont have the link handy.

Yeah I read through the list. I’m just surprised how few “supported” brands they have on there.


Also it’s really hard to come by some of the supported cards here in EU. Had to order the IOGear, PCIE, 2-Port (GIC320U) from the US, which means a massive extra shipping costs for something as lowend as an USB3 pci-e card. Doh.

Well, I just hope it works with Windows 8. In the meantime I’ve been backing up stuff using another computer with native USB3. That still disconnects once in a while so it will only transfer about 1 TB before it disconnects only to reconnect 10s later. Really annoying that you can’t trust it to do a proper backup without babysitting it all the time!

I have thunderbolt on this windows machine. I would just love to tuck the drobo away in the next room with the servers!

Yes, I have Thunderbolt 2 on my windows machine too but Drobo still doesnt support Thunderbolt on Windows. I was quite disappointed about that. I started a thread about it but there seems to be no news or updates about when that will happen. They should really implement Thunderbolt on Windows now to give people another option besides USB 3.0

Okay so an update and maybe it will help others as well.

We bought the IOgear GIC320u that Drobo has on their list of products that work. The only concern I had was that there are no drivers for windows 8.1. But we took the chance.

Windows showed the device but with microsofts own drivers. Even though I tried to install the win7 drivers in compatibility mode it just wouldn’t show up using anything other than microsofts drivers. I couldn’t update the firmware either because of that. Anyways I decided I would just test the drive and so far it has been running smoothly with just microsofts drivers.

So now we are up and running! :stuck_out_tongue:
With 5 x WD RED 4TB drives it does around 170 write and 200 read.

well done :slight_smile: