Drobo 5C - Not showing up in Dashboard, HD blinking Orange/Green

Hello there,

seems I am not alone with my problems regarding the Drobo 5C and I was wondering if you guys could help me, in comparison to the support, that does not reply and care at all it seems.

Here’s the issue:

I have been using Drobo 5C for 5 years now to back up all my studio recordings from my clients here at my recording studio. So it got used only 1-2 times a month for archiving/backup, since I have an internal project drive aswell. Silly me, for thinking their proprietary Raid system is reliable and failsafe. Now after years without problems and (perhaps) after switching to an M1 Mac with OS 12.5.1 it started to get fishy.

  • First the Drobo 5C started disconnecting while transferring big projects of 10-150GB. It just dismounted and I was not able to transfer big projects anymore.
  • Then I actually could not get it to show up in the Drobo dashboard anymore, just for a short time, so I tried around with different Macs here and ports available with no success.
  • By that time I discovered that the lights were blinking green/orange, but since it was not appearing in the Dashboard did not know, that this is the Data Protection mode and I made the mistake to power it down several times.
  • Then I powered it down, emptied the slots and powered it up. The upper bay appeared red and the Drobo still was not showing up in dashboard. Powered down again and re-inserted the drives in the bays in the exact order.
  • Now I have it connected to a USB-C port directly at the rear of the Mac mini and it is showing green/orange blinking lights but is not showing up in the dashboard so I cannot tell is it in data protection mode or not.

Anyhow I am planning to let it run now for 1-2 days to see if this is going somewhere.

All Hard Drives are WD Red/Green with 2-4 TB and were all green but the upper one, that was orange for while, but I was not alarmed by that anyhow. The data on the Drobo is more than precious to me, since I have no other backup and it contains the client projects of the last 10 years. I know, my own fault but in deed, I would be more than glad to get a bit of help here to save my data from loss and move on to another storage solution.

Thanks!
Rawand

Little update here:

After Data Protection mode was running now for almost 48 hours, I came back to find this:

  • Drobo was in Standby Mode
  • Drobo not recognized in the dashboard
  • After powering down and up the Drobo shows the following light configuration:
    Bay 1: Solid Red (Used to be the drive that showed a Solid Yellow for a while, but I left it in)
    Bay 2.5; Blinking Green and Yellow

7/10 of the blue lights in the lower area are solid blue.

What possibilities do I have here?

Is it recommended to power it down and replace the drive in the first bay?
Or can I just eject the first bay and see if the setup runs without the drive?

Actually without seeing the Drobo in the Dashboard I am having problems
to find out my used storage space or create a diagnostic file.

I am on a M1 Mac Mini with 12.5.1 Monterey.

Would be great to get some feedback!

Thanks a lot!
Rawand

Are you able to ascertain whether the drive that is now red is spinning?
If it is, it needs to be replaced with a larger drive. Make sure it is a CMR drive not a SMR drive.

Silly Drobo, sending you an orange warning light for a failing or full drive and you choosing to ignore it.

Hey TwinTiger,

thanks for getting back and yes, my fault for ignoring that “orange” light, yet I was not expecting it to be that critical as it turned out to be.

Anyhow, how can I tell if the upper drive is spinning? I tried to run the drobo with only one drive inserted and it sounded like its spinning, but actually the drobo fan is louder than the HD noise, so it’s hard to tell.

My currently used HDs seem to be all wrong, being SMR drives:

Bay1: WD Red 3TB
Bay2: WD Green 2TB
Bay3: WD Red 3TB
Bay4: WD Red 3TB
Bay5: WD Red 4TB

I now would order a replacement drive for Bay one,
being a WD Red Plus with 4TB (CMR) and try my luck with that.

What do you think?

Greets,
Rawand

Edit: The drobo just showed up first time since a week in the Finder. I could for the first
time access dashboard and download diag file and storage information. It tells me that recovery
mode will now run for about 40 hours. Long enough for me to order and install the new hard drive.



I would definitely invest in a 4TB Red plus, and substitute it in for your failed drive. Currently your data is not replicated but in theory, safe. Loading the new drive will allow your Drobo to replicate all the data across the array but this will take time. Your drives will be flashing yellow/green during the process so make sure it is given the time it needs.

Ideally the drobo dashboard will monitor this process but we are talking days here, but your data should be accessible. However every time you access your Drobo it slows down the replication process. So see if you can avoid that.

You will probably also find that very soon that your drobo will request another drive upgrade too. Upgrades mostly come in pairs. It’s a RAID thing.

Bought the Red Plus and built it in.

Seems it has repaired the dataset and works again!

Thanks for your help!

And then this happened (!!!)…will let it run now but it seems I need another
fresh non-SMR drive to get this thing running again…

I will also look out for a Synology 4-6 Bay NAS to replace the Drobo.

I’m not sure what I’m looking at here? Drive 0 - is that your new CMR drive and now Drive 1 has failed (SMR)? If so - yes - it will be a process of exchanging out your SMR drives progressively. As I am seeing yellow lights (assuming it is blinking yellow/green), you have access to your data but is it just not replicated (again).

Regardless of whether you stay with your Drobo (and follow the CMR path) or change to another RAID unit, the single point of failure will always be the RAID machine itself, so always have an external updated copy of your data kept separate to your RAID unit.

If this helps, I have 2 individual SMR drives in a stack of older smaller drives that I use as an external copy of my Drobo array’s active data.