Drobo 5C - Fails to respond

Hi all. first post, ive done a forum search but nothing came back.

Ive not long got a Drobo 5C, downloaded software/all updates/factory restore etc etc.

Im trying to migrate my drives from being attached to the rubbish mobo i have into the 5C - i then plan on shrinking my system into a smaller form factor. - to complete these im expecting to do the below.

Current Setup:
OS – 250gb Drive
RAID5 – 1x 2TB Drive / 2x 1TB Drive
Other Hardware – i7 4770 / 8GB ram / Lenovo M93p board (USB3)
OS – Windows Server 2012 R2

The plan:

  1. Take the 2TB out of the RAID5 - add to drobo, let it format/create volume etc
  2. Copy data from the ‘broken’ RAID5 volume over to the drobo
  3. add 2x1TB drives to drobo for redundancy/expansion

The problem:
Every time i start a file copy (ive tried windows copy and Syncback free & pro) it runs for a little bit then the dobro crashes - Server is still all responding ok - re-boot the drobo (have to leave the power out until it turns off) and start again.

All HDD are in healthy state when checked SMART under windows (pre-migration)

I also tried a very old 500GB drive by itself in the drobo but same issue.

Anyone seen this before? i do not have any other spare drives to create redundancy until i migrate the data

hi martin, welcome :slight_smile:

this is interesting, as i use syncback in several ways on my Das drobos and it works a treat.
(even from computer to drobo, vice versa, and drobo to drobo, and even volume 1 on a drobo to volume 2 on the same drobo)

do you know if there is anything else running on that windows machine, that could possibly be conflicting somehow?
things like readyboost, antivirus, windows search indexing etc

maybe you could try again with any of those disabled, if not already, along with another usb cable (or usb port?) just as a test?

Hi Paul.

Ill be honest ive not touched the windows installation, i will have a look at them as soon as i can.

Sadly i do not have another USB C cable about (first world problems right!) to try out. but i can try it hooked into a different PC to rule out everything.

Ill also grab some USB3 sticks and see if i can re-create the same issues using something else on the USB3 hub.

Thanks, Martin.

So ive been doing some testing this morning with the device, tried 3 machines and same issue each time.

On one of them i did get an error message which was a System IO Exception, the file trying to be written was in use already by another program (ensured it is not)

Might raise a support case next.

thanks for more info martin,
sure a support ticket might help uncover something, possibly a drive has started to play up but has not hard failed yet.

if you do get any steps to try from the support team, then please do follow their advice first,
though one thing that may be worth trying, is to shutdown all other programs, and then to try running a windows chkdsk, on each volume that you have on your drobo, one volume at a time, in 2 to 3 passes…

you might already know about checkdisk though just for completeness…
to open up a console dos prompt (ideally run as admin)

for example, if you have 2 volumes (drive letters d and e)
to try this:
chkdsk d:
(and see if it shows anything untoward)
then to try this:
chkdsk d: /x
(and see if at the end, you get a message about checkdisk finding no problems)
if you dont get that message, then to run this again:
chkdsk d: /x
(hopefully that will be enough to fix it but in some cases it may need another pass)

then to exit that console prompt, and to do the same approach for the other E volume.

btw, has the drobo been tried, as the only other device plugged into the system?
maybe you can try another kind of copy test, such as from main computer to connected drobo?