Drobo 2nd Gen Performance questions


The wakeup issue is: Given the performance, or lack of, the Drobo is only usable as a pure backup device, imo. For small files. Now such a device should not be running all the time. So i want to put it in standby mode, and wake it up when i need it.

That can only be accomplished by unplugging.


This is absolutely ridiculous. Drobo’s speed is regressing! I started off with a 22.5MB/s write and 30MB/s read. Under the exact same test conditions and contents on the Drobo, with the same drives, my test is giving me a 17.2MB/s write and 22.3MB/s read! And yet, no one has any clue why, or better yet, how to reclaim speeds!

Data Robotics, we need some answers.

why should the device not be running all the time? it would consume minimal power when the drives are spun down which it does after 15 minutes

Let’s phrase it that way. Even minimal power is too much for a backup only device that i would use once a week (given the perf, it’s not usable for anything else).

And, shouldn’t it be up to me?

And, considering we are living in a time where everything, starting with my toaster, has a sleep/resume option, wakeuponlan, etc, it’s kind of disappointing to be able to put the Drobo in Standby per software, but not wake it up again.


well if its only once a week - surely you can get the device its plugged in to reboot? (which would wake up drobo) or simply manually plug it in once a week, that cant be much harder than it would be to grope around the back of drobo looking for a power switch?

wait. When i put the drobo in STANDBY, it is not off. I am not looking for a powerswitch. What i want is a remote possibility (like wakeuponlan) to just wake it up again without rebooting my machine.

Beside, a device should do what i want it to do. It should not force me to change my pattern, as long as there is no good reason.

But, that is all not important. The performance, or lack of, was the main reason i returned my drobo. Also, Data loss due to power is much more likely with a drobo than it is with a real NAS system. I can unplug other systems, and if i loose something it might loose the data that get’s written in that moment. With Drobo, a powerloss might be catastrohpic (at least that is what the documentation states).


i was comparing it to the drobopro - where the “power” switch can be used to wake it from standby

well different devices have differing levels of control - thats the choice you make when you buy them. i have had HP printers which power cycle in a similar way to drobo, waking up and sleeping with the machine they are attached to.

data loss is more like with a DAS than a NAS - but that is the same for all DAS / NAS devices

I’m not sure what you mean by “real” NAS - since Drobo isnt a NAS AT ALL - fake or otherwise! Its DAS - you can tell by it not having any network ports :stuck_out_tongue:

I know that the Drobo is not a NAS. There is just a set of reliability parameters commonly associated with NAS systems that the Drobo is missing. I do disagree with the “DAS is always worse than NAS”. While this is true in practice, this is not due to the nature of the attachment, but the fact that most DAS systems are pretty much dumb external harddrives.

The Drobo tries to be different, and at least in my use case fails, both in the performance and in the reliability department.

Too bad, the box was so nice :slight_smile:


On the wakeup thing, once upon a time I wanted to do something similar - trigger a Safely remove (so the USB device powered down/off) and emulate the USB insertion. The goal was to be able to turn a USB Bluetooth dongle on or off. Enable/Disable via Device Manager wasn’t quite enough.

I was unable to do so via software. It looks like the USB spec is designed such that one of the connection (forget if it’s data or power) happens just slightly before the other, which triggers the USB insertion and wake up.

I couldn’t find a controllable “USB unplug/isolator” thing either and ended up giving up on that project.

I am editing a feature length documentary with Final Cut Pro. I found out the hard way that my Drobo couldn’t capture, without dropping frames. My work around has been to capture using a regular lacie firewire drive, and then copying the media over to my drobo, and editing from the media stored there (I have a huge amount of media). I thought it was working until today I find a clip that stutters and won’t play the video (when playing with audio only it is fine). I went back to the Lacie drive, and that clip is fine. Something happened when I COPIED the media to the drobo. What’s that about? How can the dobo be used as a back up device for media files if the media gets damaged in the copying process?


I’m not sure by your description: Does the clip stutter and not play when you play it directly from the Drobo, but is fine when played directly from the Lacie? Or is it that if you copy the file from the Drobo to a local hard drive, it won’t play well, but the same file copied from the Lacie to a local hard drive plays fine?

The data of the copy on the Drobo is likely fine and bit-wise identical to the copy on your Lacie drive.
More likely it’s simply that the Drobo’s transfer rate isn’t sufficient for the video playback in real-time.
This is especially likely if you’re reading multiple files from the Drobo.

What you need to look at is the data rate of the video file. People like to measure in resolution, saying things like “Mine can play 1080p!” but that is meaningless because compression is (usually) resolution-independent and data rates can be all over the map. You can have 1080p video at 2 Mbps, while 480i (standard definition) video at 160 Mbps.

Case-in-point 1080i video in HDV format is 25 Mbps, so is 720i video in DV format. So it really comes down to the data rates of the video and audio files you’re working with compared to what your storage system can reliably sustain.

I think part of the “disappointment” is the common misunderstanding that RAID means faster access and transfer rates compared to bare drives, and this is not always true. Case-in-point RAID-1 provides little, if any, speed improvement on read, while providing no improvement on write.

I can confirm this. Hands down. (I have Drobo v2, Win XP Home. I’ve done USB2 and FW800 connection and it really doesn’t make much difference on average in reality)

No one knows how DRI actually tested things to get that kind of bandwidth to/from disk on a Drobo v2 connected to FW800 because they’ve never told. Quite a few ppl have tried, both perf testing their Drobo v2s and trying to get DRI to make a statment about it. To no avail. In practice a Drobo v2 is slow. Period. It’s not faster than a FW400 single disk drive in real life, in my experience (quite extensive I might add) on a USB2 connection it’s on average a bit slower than a fast 7200 rpm well tuned and partition-aligned USB2 connected single drive. Yes, that means the performance graphs displayed on the DRI web site is an almost-lie. IMO anyway… You can get a Drobo v2 to show numbers pretty close to those 50 MB/s, for a very short period of time and only when the box is more or less empty.

With all the bitching and moaing ppl have done about this poor real-life performance of Drobo v2 in this and the previous Forum (which was hosted outside DRI), not once has any representative of DRI said anything specific about it other than pointing to potential connection issues with the computer, problems with something outside the Drobo v2… Suggestions that you perhaps don’t really have S400 but only S800 etc.

Someone made an educated guess way back at the beginning of this year in the old Forum that died when DRI terminated the contract with that external partner, that the FW800 chipset, the I/O connection between it and the ARM CPU in the Drobo v2, is just too weak HW to get any better than this with BeyondRAID processing in mind once you have some files on the box.

Even worse for me, FW800 wasn’t stable on MS Win XP FW800 drivers (long story) and the latest Unibrain drivers at the time I worked on it weren’t stable when plugging the Drobo in and out etc. So in the end I gave up on FW800 altgether and run Drobo v2 as a big external USB2 disk (archive/backup). It’s very stable, port multiplication works perfect with USB2 (no surprise there), no issues. Of course, it’s slow. Did I mention it’s slow? (sorry couldn’t help myself)

Sorry… Your Drobo v2 is never going to compete with your FW400 external drive. Not in real life and certainly not on average bandwidth.

I was disappointed just as you are. I got over it and bought some other stuff to cater for my performance need – SiI 5744 SteelVine based external disk box with eSATA with room for max 2x 2TB drives. It’s fast :slight_smile:

The Drobo v2 is just a huge USB2 external drive = file archive for most usage patterns. But it’s got RAID and it’s a very flexible RAID, so…


i’m pretty sure they have - there’s a thread on here where someone is complaining that he has used the exactly software dri did (i forget what unfortunately since he was mac based) and his perf numbers dont match theirs


well… i can search for it… or you can search for it… and im very lazy :stuck_out_tongue:

[quote=“fmantek, post:15, topic:748”]
I am returning mine. After 10days of testing i had the following nice observation:

The longer the write is sustained on the drobo, the slower it gets. I tried, with SuperDuper, to copy 260 GB from a ReadyNAS NV+ to the Drobo (which was empty at that time). This took 48 hours, and was NOT done. Write speed dropped from initial 10MB/s to 0.5MB/s at the end.[/quote]

I am seeing the same thing. When copying large amounts of data to my Drobo v2, it starts off at a decent speed but eventually slows to an unbearable crawl. I am currnetly trying to copy 900GB worth of data to it. It has been over 3 days and it’s still not done! There’s about 200GB left and Finder is telling me it will be about another 24 hours, which is suspect is an optimistic estimate.

Also, during this copy, the blue LEDs on the Drobo have not reflected how much HD space is used.

Is this normal??? Thanks.

Great to know you can reply to posts within minutes though.

To anyone else who’s interested, these are the posts I could find that came close to throughput speeds. Sadly, no one has directly challenged it, or gotten a straight answer from DRI themselves.


i said i was lazy, not busy.

i think it was under one of the drobopro threads

By now i have returned the Drobo and replaced it with a ReadyNAS NVX. With the exact same harddrives, here are the test results using a standard network.

Standard Test Results:
Test Cycles: 1

Transfer Size Sequential Read Sequential Write Random Read Random Write

4 KBytes 8.894 MB/Sec 0.405 MB/Sec 8.307 MB/Sec 0.282 MB/Sec
8 KBytes 15.846 MB/Sec 0.853 MB/Sec 15.432 MB/Sec 0.494 MB/Sec
16 KBytes 30.855 MB/Sec 1.382 MB/Sec 30.976 MB/Sec 1.023 MB/Sec
32 KBytes 8.204 MB/Sec 2.227 MB/Sec 41.623 MB/Sec 1.813 MB/Sec
64 KBytes 62.243 MB/Sec 4.734 MB/Sec 44.251 MB/Sec 2.375 MB/Sec
128 KBytes 78.871 MB/Sec 6.604 MB/Sec 77.649 MB/Sec 3.564 MB/Sec
256 KBytes 90.678 MB/Sec 10.740 MB/Sec 74.426 MB/Sec 9.797 MB/Sec
512 KBytes 99.974 MB/Sec 16.287 MB/Sec 53.137 MB/Sec 19.484 MB/Sec
1024 KBytes 104.490 MB/Sec 11.953 MB/Sec 96.835 MB/Sec 21.678 MB/Sec

Standard Ave 55.562 MB/Sec 6.132 MB/Sec 49.182 MB/Sec 6.723 MB/Sec

Large Test Results:
Test Cycles: 1

Transfer Size Large Read Large Write

2 MBytes 107.921 MB/Sec 14.838 MB/Sec
3 MBytes 109.310 MB/Sec 55.966 MB/Sec
4 MBytes 110.262 MB/Sec 29.933 MB/Sec
5 MBytes 109.304 MB/Sec 21.222 MB/Sec
6 MBytes 110.658 MB/Sec 41.069 MB/Sec
7 MBytes 110.865 MB/Sec 52.152 MB/Sec
8 MBytes 111.152 MB/Sec 42.887 MB/Sec
9 MBytes 111.534 MB/Sec 33.784 MB/Sec
10 MBytes 110.503 MB/Sec 39.906 MB/Sec

Large Ave 110.167 MB/Sec 36.862 MB/Sec

Extended Test Results:
Test Cycles: 1

Transfer Size Extended Read Extended Write

20 MBytes 111.825 MB/Sec 47.323 MB/Sec
30 MBytes 111.926 MB/Sec 49.298 MB/Sec
40 MBytes 112.021 MB/Sec 46.735 MB/Sec
50 MBytes 100.202 MB/Sec 52.522 MB/Sec
60 MBytes 98.644 MB/Sec 52.942 MB/Sec
70 MBytes 111.168 MB/Sec 50.459 MB/Sec
80 MBytes 111.958 MB/Sec 52.882 MB/Sec
90 MBytes 112.006 MB/Sec 54.754 MB/Sec
100 MBytes 112.020 MB/Sec 55.908 MB/Sec

Extended Ave 109.085 MB/Sec 51.425 MB/Sec

Beside the “small sequential writes” which are worse than the drobo, the performance is very much improved. Especially on the large tests, i see 4x the read and 2x the write speeds.