Drobo

Drobo 2nd Gen DiskWarrior Malfunction despite new HD

I recently had a 2nd Gen Drobo (2x 1.5TB WD Green, 1x 1TB Seagate newer firmware, 1x 750GB seagate newer firmware) give me grief. Very slow and unusable due to read speed of less than 0.03 MB/s.

Drobo was not reporting any errors.

DR support looked at diagnostics and told me 750GB drive was timing out. Took it out, 2 day relayout and no better.

DR sent me a new Drobo.

Put the diskpack back in, re did directory with Diskwarrior as per DR instructions. Worked for 1 hour and then slow again.

I figure another of the original disks is failing. Odd that 2 discs from a pack would fail!

I added a brand new 750GB seagate drive to make 4 disk pack. Again no errors. Ajax read write is 15 MB/s using FW 800. However, Drobo intermittently becomes unresponsive.

Diskwarrior reports disk malfunction.

I have copied the 1.6 TB to a Raid 0 device just so I have another copy, but with the investment I have in the Drobo, I want to use it as a backup.

I have no way of knowing which disk to replace now.

DR is not responding to my requests either from old case or a new case I have opened.

Any help appreciated.

Since you’ve backed up your data (granted, to a non-fault-tolerant device),

I’d pull the drives one-by-one from the Drobo until you find the one that’s causing problems. I’d start with the 1TB Seagate myself, but up to you.

Once you get back to a good configuration, then re-add the suspect drive(s) to confirm, and once you have a known-bad list (at least bad for Drobo), replace them (add drives one-at-a-time again to make sure none of the new drives are bad) and copy your data back to the now-good Drobo.

Have you tested the Drobo from another computer? I saw lots of strange behavior when connected to my old motherboard.

Thank you.

I have pulled the 1TB seagate and am doing a rebuild. While Drobo does its relayout, I am using DiskUtility to zero the seagate drive and will run a surface scan after.

As for other questions re testing with other computers, I had indeed done so.

@hmdrobo3, what is your case number?

Also, please remember, we are not open on the weekends.

Jennifer:

Thank you for replying. I do hope you can help me.

The case has 2 numbers. They closed the first one and opened the second after the RMA process started.

100114-000000

100121-000035

My request for follow-up to DR techsupport were not during the weekend. They were early in the week. In fact, I got a reply about my shipping question, but no reply to my technical questions.

When this all staretd, I was told on the phone that I should not use Drobo as a Primary Drive and that it is intended only for backup purposes. This is not clear from your Website as there are uses that are listed as a Primary storage (not system, but for photographs etc) medium

“Connect via USB, FireWire 800, or Gigabit Ethernet
Drobo can be incorporated into your environment in a number of ways. Connect a Drobo to your laptop or desktop by USB 2.0 or FireWire 800.² Connect a Drobo to the optional DroboShare to create a networked storage server.³ Use Drobo for redundant primary storage or backup. Drobo is perfect for storing and serving photos, videos, music and office documents.”

Be that as it may, I have bought 3 Drobo units (2 of the 1st gen and 1 of the 2nd Gen). So far Dr has been good to RMA 2 units.

I am prepared to use them as backup devices only as I have invested a fair bit of money.

However, I would like to know that at least as backup devices they are going to be reliable.

it is hard to have problems and not even know which drive in a drive pack to replace.

Below is the text of my queries that have gone unanswered:

FedEx did accept the package.

Can I please ask for further technical help?

I do appreciate you sending me a replacement Drobo and power supply.

I copied all the data off the Drobo onto another drive.

I then tested each drive of the drive pack using an external USB bay. They all worked with good read write speeds on Ajax.

I then put them in the Drobo and reformatted the Drobo.

I copied the data back to the Drobo and when I ran DiskWarrior it reports that it cannot replace the directory due to hardware malfunction.

Yet the Drobo is NOT indicating any drive problems.

I have a new 750GB drive in the pack and the remaining 3 drives are as before.

How can I figure out which Drive in my drive pack is faulty?

Is it likely that 2 out of 4 drives from my original drive pack would have failed without the Drobo reporting any problems?

Thank you.


Wanda:

Thank you. I received the replacement unit yesterday. I am returning my
unit and power brick today.

I followed your instructions.

Diskwarrior had no trouble quickly rebuilding the directory.

I then tried to backup the contents to another drive. It got stuck again.
I tried AJAX and read speed was less than 0.03 MB/s.

I had purchased a new 750GB drive which I popped into the 4th bay.

Tried again and read speed was up to 17 MB/s.

I am currently copying the 1.4TB over.

I realize that as you said the trouble must be one of the drives.

My question is this:

How can I tell which drive if Drobo isn’t reporting any problems?

You already indicated that the previous 750GB was failing. It is odd that a
second drive would fail as well, but regardless, how can I tell which drive
to replace?

Drobo is supposed to be about data protection and part of that is telling
you which drives are failing, isn’t it?

Thank you again for your help.


You requested technical assistance on your RMA case. The warehouseman has forwarded your questions to the technician that was assisting you. She will assist you as soon as possible.

Thank you.

As you know, I took the Seagate 1TB drive out.

I did a surface scan using Drive Genius and while it did not detect any bad blocks, it failed to read after a short while.

I zeroed it out using Disk Utility, repeated the surface scan, and it passed a surface scan. No bad blocks.

My Drobo with 3 remaining drives continued to exhibit the same behaviour, despite a clean directory rebuild with Diskwarrior. It would slow down to a crawl and become unusable. I figured it wasn’t going to work for me, so I decided to check the other drives.

So I assumed that the culprit drive was one of the other drives.

I took out the Western Digital drives and did surface scans on both of them.

Drive Genius FAILED to read from BOTH! Again, no bad blocks were found, but it failed to read.

I have started zeroing out the first of the 1.5TB drives.

Something is very odd. It doesn’t make sense that ALL 4 drives in a disk pack would all fail at the same time.

Furthermore, it is odd that they cannot be read by a surface scan tool, but after being zeroed out they pass with flying colours.

So at the end of this, I will have a “new” RMA’d Drobo 2nd Gen with the following drives to choose from:

  1. Zeroed 1.5TB WD caviar green drives x2
  2. Brand New unused Hitachi Deskstar 1TB 7200rpm 32 MB cache
  3. zeroed 1TB seagate that now passes surface scan
  4. New 750GB seagate drive that has been in the now dismantled Drobo DiskPack for 2 days. I will likely zero this out and surface scan.

Basically this setup SHOULD be enough to get me the equivalent of a BRAND NEW DROBO and new Drive Disk Pack.

I would appreciate any suggestions.

I suspect Drive Genius as a fault here, unless you find a drive that Drive Genius can check.

There is the possibility that somehow, some way, you really do have 4 bad drives, but that is very, very unlikely.

Is there a different program you can try?

Here’s a way-out possibility: A very few Drobos have experienced fan failure. When this happens, the temperature inside the Drobo enclosure has gotten high enough to melt the plastic frame.

Is your fan running? If you have a defective fan, you just possibly might have cooked all four drives.